Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

i think i need a new engine.....

PaRaDoX

Because Racecouch...
Joined
Apr 16, 2005
Messages
3,286
Reaction score
33
Points
48
Location
Melbourne, Victoria
Members Ride
none
hey,

was driving to work today, due to petrol prices being soo high ive been using unleaded 92 (pings its tits on on my engine)

anyway, the cars been running low on oil for a while, just finished spraying the bodykit today... was driving up a hill, car was pining like usual on crap fuel.. and all of a sudden when i took my foot off the accelerator after reaching the top i heard a loud clicking sound.... i was nearly at work when i stopped to check it,
someone came and asked if i needed help,

at first i thought it was the harmonic balancer but i checked it its pretty new (been replaced in the last 60,000km)

anyway after adding oil the car seemed to run a bit better but not good,

as is, it idles like it has the fattest cam in the world, feels like it has no power, after 3000rpm is has no power, was dropping revs while going up a hill on the way home.. its still drivable, but i think the engines been damaged,

i need ideas??
does anyone think my engines dead or could it be something else???

i have access to a block and tackle, a 2nd hand running S1 3800 (early 90 model i think) so a new engine wont be a problem, it will be alot of work but i was thinking if i have to do it, i may aswell do it with some good parts

if i have to rebuild it i was thinking of
C.O.M.E Cam shaft
A.C.L racekit
something like this
http://www.aclperformance.com.au/Holden3.8EngineRebuildKitSeries1.htm

anything else worth doing for reconditioning a engine???

should i be driving it like it is???
 

greenfoam

New Member
Joined
Jan 13, 2005
Messages
7,900
Reaction score
124
Points
0
Age
99
Members Ride
VP Executive R-spec
Might have melted a spark plug due to all the pinging, worth a look anyway. If it's not that something else is probably busted. Maybe pull the cap off the rocker cover, give it a rev and look for smoke
 

PaRaDoX

Because Racecouch...
Joined
Apr 16, 2005
Messages
3,286
Reaction score
33
Points
48
Location
Melbourne, Victoria
Members Ride
none
feels like its not running on all 6 cyclinders so maybe, feels like its missing 1 or 2 cyclinders might make a stop to the wreckers tommorrow and pick up some 2nd hand plugs just to test

ill try removing the cap, not blowing any smoke out the exhust i dont think so, hrm, hakhawk reccomended checking fuel filter??
 

cracker

New Member
Joined
Aug 21, 2004
Messages
959
Reaction score
7
Points
0
Age
32
2nd hand plugs...they are like $2-$3 each
 

greenfoam

New Member
Joined
Jan 13, 2005
Messages
7,900
Reaction score
124
Points
0
Age
99
Members Ride
VP Executive R-spec
If it's missing two it might even be a coil pack
 

commy92

New Member
Joined
Mar 5, 2006
Messages
645
Reaction score
3
Points
0
Members Ride
VP WAGON V6
there is so much it could be? is it blowing smoke out the zorst?? is it running HOT? is it using oil? is it using water? Are all your injectores pulsing? are you gettig spark at each cyliner... there is so much more it could be its not funny. Basically you gotta start somewhere so i suggest you start where its not going to cost you any money to test. Ide look at injectors first. Turn car on.. hold each injector you should be able to feel it pulsing.. If not then bobs ya uncle. Ide then move onto coil packs.. There is a way to test these safly but im not sure so someone else might know. Ide prob then replace plugs and leads.. After that ide move more into the engine.. Compression test both banks. If alls good then ide move onto you fuel.. ide be dropping your tank and flushing it out then filling it up with some decent fuel. 92 oct is ok as long as you get it from bp or something decent.. none of that home brand crap. If all else fails after that ide go see a mechanic. Tell them what happened what you have done to check it over and see what they recon. It could be somthing so simple but yet it could also be something so stupid and annoying a new engine is on the cards.

Michael
 

PaRaDoX

Because Racecouch...
Joined
Apr 16, 2005
Messages
3,286
Reaction score
33
Points
48
Location
Melbourne, Victoria
Members Ride
none
well, after taking it for a test drive today,

(checked the oil levels, its at full now and checked plugs without removing them)

the cars running rich, VERY rich as in 50-100L per 100km
the valves are rooted, the exhust is blowing then sucking...
i hate to say it but i really think its rooted

coil packs are less than 6 months old, stage 2 coil packs and new aftermarket leads, plugs were done at the same time aswell...but its chewing fuel, blowing a bit of smoke (running rich) yeah.. ill give more info as it comes in, dosnt feel like a spark issue,

just checked injectors, not them, no smoke comming out of the rocker covers with cap off, no smoke comming out of there
compression tests cost much???

if worst comes to worst, im ready for a rebuild, got a mate who does head reconditioning... yeah just need more idea's

just had vpbt1ss round, he thinks ive rooted a pushrod, soo well see what i can do from here definatly need a compression test
 
Last edited:

commy92

New Member
Joined
Mar 5, 2006
Messages
645
Reaction score
3
Points
0
Members Ride
VP WAGON V6
yeah push rod sounds about right. My mates series 1 did it not long ago. Sounded like the engine was going without oil etc etc etc.. Ide still get the compression test and go from there. If ya mate is a head re-con dude he should be able to chuck the compression tester on for ya. Its very simple to do ya just need the tool
 
Top