Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Is this odd?

Goon

Scientific Tuning
Joined
Feb 20, 2006
Messages
2,508
Reaction score
9
Points
38
Location
BrisVegas. QLD
Members Ride
VY CUSTOM.
Well after taken my car for a few test drives, i've noticed my speedo is abit odd, but the :yeah: in the same way.

I drive upto 60km and it stops, gets stuck or something same as going above and coming down to 60k again it stops at 60k. Pressing the khm button will keep it going anytime after it stops.

I think it good , i know when i'm going above 60k :)

But still, what would cause this?

ps. the speed with the speedo it isnt out , i know this :D
 

JD

Donating Member
Joined
Aug 18, 2006
Messages
1,716
Reaction score
25
Points
48
Age
34
Location
Deep South, SA
Website
www.ccgm.au.tt
Members Ride
1.6L Turbo Holden Croooooooooooze
open up the dash and check behind the needle there might be some crap there so when it goes over 60 it stops
 

atrail308

RIP King of the Mountain
Joined
Mar 2, 2006
Messages
272
Reaction score
3
Points
0
Location
southside adelaide
Members Ride
V8 VH SL/E 308
sounds to me like a sticky speedo, try cleaning it out, if that fails you'll prob need another one...
 

Goon

Scientific Tuning
Joined
Feb 20, 2006
Messages
2,508
Reaction score
9
Points
38
Location
BrisVegas. QLD
Members Ride
VY CUSTOM.
Thanks for the advice guys, but i an't cleaning it..

It's my speed alert now :thumbsup:
 

craigvk

Banned
Joined
Jun 4, 2005
Messages
1,981
Reaction score
23
Points
38
Members Ride
VK 5L Calais
When the roadworthy tester goes up to speed and do a brake test, he'll fail you for that.
 

Goon

Scientific Tuning
Joined
Feb 20, 2006
Messages
2,508
Reaction score
9
Points
38
Location
BrisVegas. QLD
Members Ride
VY CUSTOM.
Well it passed.. maybe it worked that day :D
 

craigvk

Banned
Joined
Jun 4, 2005
Messages
1,981
Reaction score
23
Points
38
Members Ride
VK 5L Calais
It would be worth looking at fixing though. You don't want to have a broken speedo. :)
 

85berlina

New Member
Joined
Jun 27, 2006
Messages
137
Reaction score
3
Points
0
Location
Sydney
Members Ride
VK berlina sedan 202
Its not really that odd.

My VK had a busted speedo to begin with, my brothers HX still does have a broken speedo and both a HQ and a HJ I looked at had busted speedos.

They all had the same fault of a binding magnetic clutch. I guess its a common problem with old Holdens.
 
Top