Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

keeps going to the left everytime I use brakes on my VE Commodore

kevin13

New Member
Joined
Sep 1, 2013
Messages
4
Reaction score
0
Points
0
Location
Sydney NSW
Members Ride
VE Commodore International
Hi, I just bought a VE 2010 International (done only 45000), and it keeps going to the left everytime I use brakes. Can someone tell me whats wrong with my car? Thanks mate
 

HamaTime™

VIP Member
Joined
Feb 17, 2008
Messages
1,807
Reaction score
61
Points
48
Location
Melbourne
Members Ride
C Class AMG
Discs might be slightly warped. Do they shudder?

You might also need a wheel alignment (does it pull to the left on a dead straight road?).
 

morganluke

Captain Morgan
Joined
Sep 14, 2010
Messages
21
Reaction score
0
Points
1
Age
31
Location
Central Coast, NSW
Members Ride
2001 VX S Pack | 2009 Liberty GT wagon
Alignment would be be first option. Maybe even a simple wheel rotation.

With only 45k km, I doubt the discs would be warped - although I'm sure stranger things have happened...
 

Troy711

Retired Old Fart
Joined
Dec 13, 2003
Messages
7,692
Reaction score
164
Points
63
Location
Canberra, ACT
Website
forums.justcommodores.com.au
Members Ride
2011 Mitsubishi Pajero GLS
^^^ My old mans Falcon work utes (BA, BFII and FG) develop brake shudder at around 15K, even after machining or replacing the discs. My VZ ute also had bad brake shudder at 30K and I had the discs machined under warranty.
 

l.k.

New Member
Joined
Jul 2, 2013
Messages
28
Reaction score
1
Points
3
Location
auckland
Members Ride
ve sidi sv6 2010 1988 vl vacationer
^^^ My old mans Falcon work utes (BA, BFII and FG) develop brake shudder at around 15K, even after machining or replacing the discs. My VZ ute also had bad brake shudder at 30K and I had the discs machined under warranty.
id check wheel alignment first too. i always thought there was something not quite right with my steering, but couldnt put my finger on it as it was so minimal. then my other half , who is a bit more careful than me said she found it pulled slightly to left as she came to a gentle stop . i tried that out and found the same . put it in for alignment and they found left side out slightly . told me i wasnt first one to come in like that and they seemed to all be the left side and with the same setting, too . coming out of factory like it. (within acceptable engineering tolerances, i guess)
 
Top