Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

L98 e38

Discussion in 'VE Holden Commodore (2006 - 2013)' started by James Ruiz, Apr 7, 2020.

  1. James Ruiz

    James Ruiz New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 7, 2020
    Location:
    Geelong
    Members Ride:
    Ve l98
    Hey guys first post hopping to find someone that might be able to help me out. I have recently installed a 6l from a ve into a vk i had a standalone loom and vats removed from the ECU.
    When i power the ECU my fuel pump aint priming.
    Is pin 50 on the x1 connector suppose to give out 12v? Thanks ..
     
  2. 07GTS

    07GTS Well-Known Member

    Messages:
    2,036
    Likes Received:
    545
    Trophy Points:
    113
    Joined:
    Sep 8, 2013
    Location:
    Australia
    Members Ride:
    VEGTS BLOWN E85
    looks like X1 pin 50 pump relay control
     
  3. James Ruiz

    James Ruiz New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 7, 2020
    Location:
    Geelong
    Members Ride:
    Ve l98
    Thats correct except im not sure if it should be giving me 12volts or a ground at the moment it aint giving me nothing.
     
  4. Utel67

    Utel67 Active Member

    Messages:
    274
    Likes Received:
    117
    Trophy Points:
    43
    Joined:
    Jul 15, 2019
    Location:
    Tasmania
    Members Ride:
    Vs s3 ute
    Should supply ground.
     
  5. James Ruiz

    James Ruiz New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 7, 2020
    Location:
    Geelong
    Members Ride:
    Ve l98
    Ok thanks I'll check it out.
     
  6. James Ruiz

    James Ruiz New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 7, 2020
    Location:
    Geelong
    Members Ride:
    Ve l98
    Utel67 are you sure it should be asserting ground ?
     
  7. Utel67

    Utel67 Active Member

    Messages:
    274
    Likes Received:
    117
    Trophy Points:
    43
    Joined:
    Jul 15, 2019
    Location:
    Tasmania
    Members Ride:
    Vs s3 ute
    Sorry mate my mistake this should help I hope.

     
  8. _R_J_K_

    _R_J_K_ Well-Known Member

    Messages:
    4,781
    Likes Received:
    544
    Trophy Points:
    113
    Joined:
    Dec 20, 2008
    Members Ride:
    Zenki S14
    Don't know if this will be helpful for you but generally with most ECUs the pump will only turn on when there's a crank angle signal so simply powering the ECU won't do anything. When you turn the key to accessories it primes because the ECU receives a blip of crank angle signal and then it continues to pump because the starter motor is turning the crank. Stops fuel pumping in the event there's an accident or failure of some kind.
     
  9. KHOLDEN

    KHOLDEN New Member

    Messages:
    29
    Likes Received:
    7
    Trophy Points:
    3
    Joined:
    Feb 5, 2019
    Location:
    Ashhurst
    Members Ride:
    VE S2 SSV Redline ute
    It's only to switch a relay, not to run the pump
     

Share This Page