Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Losh's New Ride

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
22,612
Reaction score
22,387
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Speakers arrived today got them in tonight. Last night I fitted a SH head unit that I bought back off the step daughter for $40, which I gave her for Christmas or her birthday. Both are designed for cars and not boats but boat audio is really expensive for anything half decent, so car ones will be fine.
I still need to connect up the yellow power wire. Unfortunately you can buy yellow cable by the metre anymore so I have to spend $17-$18 and buy a roll from Mitre 10. Annoying because I only need a metre and not five metres. Tried three places to get just a metre of yellow and no luck and even by the roll I have to get it from Mitre 10 or possibly Bunnings as very few places carry it. Hopefully I can get to Mitre 10 this week and grab a roll as I'm keen to get the stereo working so I can tick that off the list. But I'm loving the look of the new speakers and head unit, so much nicer than junk proper boat audio.

20240212_222259.jpg


20240212_222210.jpg
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
22,612
Reaction score
22,387
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Things are still progressing. Today I was looking online for a fitting that connects my fuel hose to my new tank. Turns out I have bought a fairly old tank. However, tbe good news was I looked up Mercury dealers and found one 12 mins out of Town near Perth. Send photos to the lady and she sent one back. Bingo, looks right. She says no problem trying it too before I buy. And another bonus they are open until 7pm as the local Shell, which they run is part of tbe business. Get there perfect fits like thumb up a baby's bum, and only $15. I was stoked as I was expecting these to be obsolete and had purchased a tank that would be no good, but nope. All I need now is a Yamaha motor end quick fitting and Anaconda sell those for about $10. This now means I can sell both my spare tanks and recoup some funds to buy a couple more bits.

I decided to buy a 5m roll of 20a yellow cable from Mitre 10, plus some ring lugs. It was just too hard to find a place that sold it by the metre and I had already spent 30 or so mins trying to find somewhere. I may need more down the track, so even though it was $15 with my trade account it won't go to waste I'm sure.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
22,612
Reaction score
22,387
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Just got the steering rod working for the hydraulic steering. That eas supposed to be a five min job that took me over an hour. Had to unbolt motor bracket, well loosen it right off so I could get the steering rod bolt through the hole. I thought the bolt was too long so I put a washer on each side of the rod flex joint. Turns out that was a bad move, because when I tightened up the nut I couldn't get the nylock part over the thread. I had already been to Nuts and Bolts to swap the bolt over this morning. I thought the bolt was too long but turns out the one I got today was the length I needed. Then I'm trying to work by headlight as it's now dark and the power is off, and what happens I drop a nut I need...... Some searching and eventually it turns up but not on the floor like I thought but in my service cart on the second shelf..I thought it had hit the cart and bounced off. It's all together now and I'm now one more step closer to being able to get it out.

I really wanted to get the stereo install finished tonight but with no power it's not going to be easy just relying on a headlight to see. As it is I still need the headlight but I need proper light as well to see.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
22,612
Reaction score
22,387
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
I thought you would only need 15 amp cable?

Is that h/u rated at 20 amps?
Could only get 10a or 20a. Mitre 10 didn't sell 15a.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
22,612
Reaction score
22,387
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Not sure what it's rated at but it wouldn't be more than 15a I don't think, probably 10a. There is one auto electrician I could try and get to before they close but not sure if they would sell cable or not to me. I've used them once before on the old ute and they were really expensive.
 

Lex

Well-Known Member
Joined
Sep 19, 2012
Messages
5,867
Reaction score
5,228
Points
113
Location
Geelong Victoria
Members Ride
VT Executive S1 V6 6 speed Auto Wagon
Not sure what it's rated at but it wouldn't be more than 15a I don't think, probably 10a. There is one auto electrician I could try and get to before they close but not sure if they would sell cable or not to me. I've used them once before on the old ute and they were really expensive.
Personally go in, don't call, otherwise they will give a stupid price. Ask for how long the cable you need. eg. 1 meter.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
22,612
Reaction score
22,387
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Just ask for how long the cable you need. eg. 1 meter.
I have what I need for now, but I think I will need more cable in other colours at some point. I can ask and see what they say. I didn't ask because I thought they would say no. I thought Jaycar, Repco or SCA would have it but no. They used to IIRC.
 
Top