Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Losing My Mind!! (Powertrain Fault)

Zyigo

New Member
Joined
Jul 24, 2019
Messages
16
Reaction score
4
Points
3
Age
26
Location
Adelaide
Members Ride
2005 VZ SV6
Hey all, I'm a long time lurker, first time poster on need of some serious help! The car is a 2005 VZ SV6 with the LY7 alloytec and has the much anticipated powertrain fault.

It all started with a good 'ol P0443 evap purge control valve circuit fault. So I replaced the purge valve. Easy.

It didn't clear.

I then changed the spark plugs, coil packs and also the starter motor (cause it wasn't starting properly, this was fixed with the starter motor change).

I then got a P0206 (cyl6 injector circuit fault) and the car started running like absolute and complete TRASH at low revs (<1500) however this was intermittent until a mechanic reset my fuel trims as my long term was off heaps. Once the fuel trims were reset to 0% the car consistently idles horrifically and feels like it's going to perhaps stall.

I also am now showing a P2234 (O2 sensor short to heater fault). I've tried swapping the O2 sensors on the front sides to see if it would throw up a different cylinder but it didnt make a difference.

Sorry for the long winded post, and I know I'm new, but please help me. I'm out of ideas. What do I do? I don't want to replace everything just until it's fixed, I don't have cash to throw around.
 

99notout

Active Member
Joined
Aug 10, 2013
Messages
589
Reaction score
137
Points
43
Location
Adelaide
Members Ride
VZ Equip Wagon
Happy to plug in a genuine Tech2 and have a squiz for free if you are close? PM me.
 

Zyigo

New Member
Joined
Jul 24, 2019
Messages
16
Reaction score
4
Points
3
Age
26
Location
Adelaide
Members Ride
2005 VZ SV6
UPDATE
Anyone that has a problem like this, just for future reference, it was a bung ECM. $1094 from Holden in Port Adelaide for diagnosis, part and fit.
 

Fu Manchu

Septic Tank Pump Operator
Joined
Mar 18, 2006
Messages
10,194
Reaction score
8,577
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
I had a near identical situation.
O2 fault caused by both AC draining into the connector for the post cat O2 and non genuine O2 sensors.

Cats not working, replaced with some from a bloke selling some on bumtree.

Poor throttle body

Faulty MAF

Vacuum leak causing misfire

PCV blockage will also cause a bunch of idle issues, purge issues and misfires. Misfires can also be caused by faulty or worn accessories and idler pulleys creating vibration. (I learnt that from a Holden tech bulletin).
 

Zyigo

New Member
Joined
Jul 24, 2019
Messages
16
Reaction score
4
Points
3
Age
26
Location
Adelaide
Members Ride
2005 VZ SV6
Sounds like a completely ridiculous and unlucky series of unfortunate events.

Definitely interesting - Mine too was certainly a weird situation. There's really nothing to give away the fact that I had a dodgy ECM, apart from the fact that nearly everything was throwing errors of some sort. Crazy stuff. I'm just glad it's all fixed up!
 

wetwork65

A wet business
Joined
Mar 12, 2006
Messages
1,001
Reaction score
741
Points
113
Location
Sydney
Members Ride
VF SSV Wagon & VF SV6 Wagon
Sounds like a completely ridiculous and unlucky series of unfortunate events.

Definitely interesting - Mine too was certainly a weird situation. There's really nothing to give away the fact that I had a dodgy ECM, apart from the fact that nearly everything was throwing errors of some sort. Crazy stuff. I'm just glad it's all fixed up!
Thanks for posting the resolution - it helps a lot of people if this is done, rather than posting a problem, getting suggestions and then disappearing.
 

Zyigo

New Member
Joined
Jul 24, 2019
Messages
16
Reaction score
4
Points
3
Age
26
Location
Adelaide
Members Ride
2005 VZ SV6
Thanks for posting the resolution - it helps a lot of people if this is done, rather than posting a problem, getting suggestions and then disappearing.
I've used this forum too many times to not do my duty as an OP! I'll stick around now that I've bothered to make an account.
 
Top