Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Loss of top end power

Joined
Apr 3, 2012
Messages
106
Reaction score
3
Points
18
Age
37
Location
NSW
Members Ride
VY 1 Tonner S V6 Raptor Charged!
Hi all. The tonner seems to be in a spot of bother at the moment. Under hard acceleration it gets to around 4000 rpm and you can feel it losing power to the point where it struggles to make it to 5000 rpm. It doesn't splutter, jerk, misfire or anything like that. it just seems to run out of steam and kind of go nowhere. It has a Raptor on it but i'm almost certain that has nothing to do with it as it still boosts nicely up to that 4000 rpm mark before the drama starts.

I was kind of leaning towards fuel pump/filter as I have checked the leads and plugs and they seems to be fine. Here is the link to my ride thread if you wanna see the other mods etc. http://forums.justcommodores.com.au/vy-vz-wk-wl-v2/217943-vy-charged-tonner.html
 

Futech

Like a boss
Joined
Sep 14, 2012
Messages
241
Reaction score
2
Points
0
Age
48
Location
Auckland, New Zealand
Members Ride
VY 5.7
If your thinking fuel pump/filter have you put a pressure gauge on it yet and run it up?
Take it to a workshop that has a "fast" oscilloscope and knows what they are actually doing. They will be able to do on road diagnostics and pretty much should have an answer in an hour of testing.
 

07GTS

Well-Known Member
Joined
Sep 8, 2013
Messages
2,739
Reaction score
1,216
Points
113
Location
Australia
Members Ride
VEGTS BLOWN E85
belt not slipping on the blower pulley..? after i had mine i found it loosing power under hard throttle applications but was ok when easily fed worked out it was the belt slipping on the blower pulley...
 
Joined
Apr 3, 2012
Messages
106
Reaction score
3
Points
18
Age
37
Location
NSW
Members Ride
VY 1 Tonner S V6 Raptor Charged!
If your thinking fuel pump/filter have you put a pressure gauge on it yet and run it up?
Take it to a workshop that has a "fast" oscilloscope and knows what they are actually doing. They will be able to do on road diagnostics and pretty much should have an answer in an hour of testing.
I live out in the bush, so I don't know if I have access to that kind of service. Anyways, I drove the car around a bit today and it didn't exhibit any of the problems. I had a fiddle with the plugs and leads yesterday, maybe I unknowingly fixed it.
 
Joined
Apr 3, 2012
Messages
106
Reaction score
3
Points
18
Age
37
Location
NSW
Members Ride
VY 1 Tonner S V6 Raptor Charged!
belt not slipping on the blower pulley..? after i had mine i found it loosing power under hard throttle applications but was ok when easily fed worked out it was the belt slipping on the blower pulley...
I don't think it is the belt. I have never had that problem before and I don't think it would kill the power that much if it was slipping. It was really stopping dead in it's tracks.
 

HSV 671

New Member
Joined
Jan 3, 2013
Messages
213
Reaction score
0
Points
0
Location
qld
Members Ride
04 VY CLUBSPORT MM6
Does it seem restricted for power. Have you looked at your air filter. what type you got. otrcai, std or pod. My old stocka v6 magna had this issue, found the air filter to have sucked up into the pipe restricting flow. must say very unusual. Also seen it happen to a stock BMW Z3 air filter. Same symptom. Maybe a solution for you.
 

Pollushon

Boost gives me a bar....
Joined
Nov 9, 2012
Messages
2,871
Reaction score
1,263
Points
113
Location
Canberra
Members Ride
VY SS
Sounds like mine the few weeks before I fitted the rising rate reg, ran out of fuel up high. Not saying yours needs the 60psi, but a dying fuel reg or vacuum leak might be another cause. Easy to check for, pull off the vacuum line and have a sniff.

Hope you're right about the electrics you played with. Maybe it's just asking for that water/meth :)
 
Joined
Apr 3, 2012
Messages
106
Reaction score
3
Points
18
Age
37
Location
NSW
Members Ride
VY 1 Tonner S V6 Raptor Charged!
Thanks for all the suggestions guys. I'll give it a good once over tomorrow arvo.
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,993
Reaction score
441
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
is it tuned yet and is it spraying meth
 
Top