Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Ls1 Cross8 Crewman 2004 oil light comes on when warmed up

purelydaniel

New Member
Joined
Dec 4, 2014
Messages
8
Reaction score
0
Points
1
Age
30
Location
mount isa
Members Ride
vy ute, lj torana
Hey guys if it has been mentioned or ask before let me start by apologising.

i have a 2004 crew man ute as mentioned with 340,000ks on it, I have noticed when she warms up the oil light comes on, as if to say add oil. But the oil is fine., it has been changed three times flushed the first two. Also using Gulf Western oil, and thought after reading around it may be a oil pressure sender behind the manifold, so I changed that. But it hasn’t done anything, any other suggestions? Or same problems?
I hope it’s not a pick up o-ring in the sump, because it’s a cross8 and apparently the front drivetrain and assemble is in the way of taking sump off. Any help and knowledge would be much appreciated
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
6,934
Reaction score
4,184
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
Step one. Plug in a obd2 code reader. Get the code generated. The oil light should set a code. I’d bet it’s low pressure. An ‘04 wouldn’t have the oil pressure gauge on the centre binnacle would have the vehicle orientation gauges yeah?

Where are you loosing pressure will be a tricky one to answer. It hopefully is via the oil pressure sensor. Lots of other places.
 

purelydaniel

New Member
Joined
Dec 4, 2014
Messages
8
Reaction score
0
Points
1
Age
30
Location
mount isa
Members Ride
vy ute, lj torana
Hey, thank you for the reply, as for the scanner as of yet I haven't plugged my scanner in to tell me but until then I can only guess. I will this weekend and see what it comes up with. As for the different areas to check, if it is oil pressure where else can I check?

Also should have mentioned it's had a upgrade oil pump installed, but it has been having this issue before instal.so I have just parked it up for now.
 

mpower

Well-Known Member
Joined
Jan 22, 2007
Messages
4,728
Reaction score
1,229
Points
113
Location
Brisbane
Members Ride
V2 CV8 Monaro and VF SSV Redline
sender throws the engine light code - ffs mate read the codes don't just chuck bits at it.
 

purelydaniel

New Member
Joined
Dec 4, 2014
Messages
8
Reaction score
0
Points
1
Age
30
Location
mount isa
Members Ride
vy ute, lj torana
Sorry mate next time I am able to get my reader I will be checking it. It's not like I'm throwing your money away mate ffs. But yes sir I will read the code when I can
 

mpower

Well-Known Member
Joined
Jan 22, 2007
Messages
4,728
Reaction score
1,229
Points
113
Location
Brisbane
Members Ride
V2 CV8 Monaro and VF SSV Redline
Sorry mate next time I am able to get my reader I will be checking it. It's not like I'm throwing your money away mate ffs. But yes sir I will read the code when I can
you are, the sender would have been fine.
 

purelydaniel

New Member
Joined
Dec 4, 2014
Messages
8
Reaction score
0
Points
1
Age
30
Location
mount isa
Members Ride
vy ute, lj torana
Well I'll read it let you know what the code said and get my money back for the sender, sounds good?
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
6,934
Reaction score
4,184
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
If the sender is rooted, normally you’ll have oil everywhere at the back of the motor.
 

mpower

Well-Known Member
Joined
Jan 22, 2007
Messages
4,728
Reaction score
1,229
Points
113
Location
Brisbane
Members Ride
V2 CV8 Monaro and VF SSV Redline
If the sender is rooted, normally you’ll have oil everywhere at the back of the motor.
having had to replace a sender that's not the case, it just won't read and throws a code - hopefully once the OP reads his codes he'll have an idea of where the issue is.

swapsie partsy makes no sense on a "modern" car. not unless the codes are inaccurate and misleading (think ABS module).
 

purelydaniel

New Member
Joined
Dec 4, 2014
Messages
8
Reaction score
0
Points
1
Age
30
Location
mount isa
Members Ride
vy ute, lj torana
So the code reader didn't pick up anything which was weird. But it still comes up with check oil and then there was what sounded like lifter noise. So I shut it straight off. So to me sounds like starving of oil up the top end? I've read about the oring in the oil pick up may need replacing but would that be it? And has anyone with a cross 8 had this issue? Is the pick up in the sump, and can the sump be removed without taking motor out as it's a awd drivelines maybe in the way. Any help appreciated
 
Top