Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

ls1 throttle body, urgent help required

VYBR8R

VYBR8NV8
Joined
Jan 12, 2009
Messages
67
Reaction score
1
Points
0
Location
Port Kennedy
Members Ride
VY SS ute 5.7/A4
gday guys, ive recently purchased an 85mm BBK throttle body for my ls1.
had a few issues installing it, the orginal bolts into the intake manifold were too short, thats been rectified. but the issue i have now is the throttle cable has some slack in it and the cruise control is too short and wont reach. anybody out there know how to adjust the cables. there doesnt appear to be anywhere you can, ive checked inside the cabin at the pedals, any help would be greatly appreciated. Also is anyone familiar with this throttle body, as my idle speed has increased 500rpm, im not sure if this is due to the increased air flow (bearing in mind i had a ported standard TB) or is the throttle position sensor, i noticed when i brought the sensor over from the original TB that it was angled slightly different, note theres 3 different postions you can fix the sensor in. might try them all see if that effects the idle speed. any advice would be great. :)
 

vt1538

455rwhp LS3
Joined
Sep 28, 2005
Messages
897
Reaction score
23
Points
0
Age
52
Location
The Dead Centre
Members Ride
VY SS S2 [email protected]
There is a cable adjuster half way down the cable. Lift up the tab, remove the slack & push the tab back down. Takes about 5 seconds.
With the BBK throttle body you should have also recieved a new cable mounting plate which offsets the cruise control cable to make it work.
The idle set screw may need to be adjusted as well as a tps sensor reset. To reset the tps disconnect it at the TB. Turn on the key until the fault light comes on. Turn off key, reconnect TPS sensor & you are good to go. You will need a few starts before the idle trims are relearnt. If someone has drilled the throttle plate to suit a cam & you have a standard engine you may never regain idle control until this is rectified.
If you cant get it in these few steps consult your local tunershop.
 

walesy

Aint no family cruiser!!!
Joined
Jun 10, 2005
Messages
2,254
Reaction score
17
Points
38
Age
33
Location
Perth SOR
Members Ride
Cherry Black WH II Caprice, VS exec wagon
nahh he has a cam aswell... lazy ass doesnt come on here that often ill give him a call and see if he got your reply...

11.3 thats a nice time! 2 seconds quicker than my caprice haha im lookin at gettin it on the bottle soon... need to get my 3.9s,stally and shiftkit sorted too :p
 

eroled

VY SS
Joined
Mar 17, 2009
Messages
41
Reaction score
0
Points
6
Location
Gold Coast
Members Ride
VY SS
There is a cable adjuster half way down the cable. Lift up the tab, remove the slack & push the tab back down. Takes about 5 seconds.
With the BBK throttle body you should have also recieved a new cable mounting plate which offsets the cruise control cable to make it work.
The idle set screw may need to be adjusted as well as a tps sensor reset. To reset the tps disconnect it at the TB. Turn on the key until the fault light comes on. Turn off key, reconnect TPS sensor & you are good to go. You will need a few starts before the idle trims are relearnt. If someone has drilled the throttle plate to suit a cam & you have a standard engine you may never regain idle control until this is rectified.
If you cant get it in these few steps consult your local tunershop.
Hi all , I hope someone can help I also have installed a larger TB and it come with a spacer to go in between manifold and TB and i now need this cable mounting plate for the cable to reach were can I buy one as it didnt come with one .
I live on the Gold Coast so if there is somewhere around here were I can buy one that would be even better .Cheers Phil
 
Top