Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

LS1 ticking noise on cold start up.

someguy360

Beer, bacon and speed parts.
Joined
Jan 29, 2011
Messages
2,630
Reaction score
1,227
Points
113
Location
SA
Members Ride
94' VR 304 - 05' Navara - 12' Sorento
My car has done 417000 K My. Loud ticking Notice sounds like Tappets or like a Diesel Engine. .when engine gets Hot after 20 minutes running The noise is not as loud. What's your opinion please
Lifters on an LS generally tend to start getting pretty tired and sloppy from around 200,000 onwards.

A new set of lifters is probably the only fix, you could try a bottle of lifter freeup in the oil but I'm not confident at that milage it will do much but worth a shot.

The fact that it gets quieter as it gets hot is a good sign that it's not a worn engine/bearing clearance issue.
 

Johandre Fouche

New Member
Joined
Jan 15, 2022
Messages
1
Reaction score
0
Points
1
Age
26
Location
Port Elizabeth, South Africa
Members Ride
Holden Commodore VE 6.0 V8 2009
Hi all,

I live in South Africa and drive a Chevrolet Lumina (Rebranded Holden Commodore VE 2009 6.0 V8 L98).

I also have the slight ticking noise - does anyone perhaps know of alternatives to "Lifter-Free and Tune-Up"?

This is not available in SA, and can't seem to find a shop that does international shipping.

Thanks.
 
Top