Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

my 66' impala hardtop :)

Discussion in 'Projects' started by ari666, Jul 16, 2009.

  1. hi_ryder

    hi_ryder Donating Member

    Messages:
    3,348
    Likes Received:
    103
    Trophy Points:
    63
    Joined:
    Aug 27, 2008
    Location:
    Pascoe Vale South, MEL
    Members Ride:
    vp calais ls1, vp berlina 3.8L
    [​IMG]
     
  2. 383 hatch

    383 hatch Well-Known Member

    Messages:
    3,922
    Likes Received:
    63
    Trophy Points:
    48
    Joined:
    Jun 14, 2005
    Location:
    Cowes, Phillip Island
    Members Ride:
    VG Ute 5.0,Torana hatch 383,WB Ute 5.0,VR stato5.0
    Looks good Ari, nice to see it all painted. However, you forgot to paint the roof, it's still white? Haha. Also, excuse my ignorance, but at what point in the never ending build didn't you change the front sheetmetal?
     
  3. Trayner

    Trayner Fresh prince of Pakky

    Messages:
    1,411
    Likes Received:
    90
    Trophy Points:
    48
    Joined:
    Aug 21, 2008
    Location:
    Pakenham , VIC
    Members Ride:
    Vz ss 6.0L Thunder , Vz S One Tonner
    Looking awesome ari , needs some wires on it now
     
  4. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
    you mean the 65' front end? that got changed maybe a year into the build. the 65 guards were fked, had to chop massive patches off, so sourced the proper 66 front and swapped. paid 500 +my old front.

    65 guards:
    [​IMG]

    [​IMG]

    ah here we go:

    in hindsight, it wouldve made the car more desirable/more valuable if i hadve stuck to the front and put a 65 rear on. the 1/4's for 65 are available from china, then wouldve just had to source the boot and whatnot. my whole rear end was fked anyway.
     
  5. Hoska91

    Hoska91 Formerly 75HJPREM

    Messages:
    244
    Likes Received:
    1
    Trophy Points:
    18
    Joined:
    Jun 17, 2010
    Location:
    Perth
    Members Ride:
    Getz Lyfe & E34 Project
    Hind sight is a wonderful thing for that reason ari, best not to dwell on it, coming to the end game now and you shuold be happy with all you've learned and produced especially seeing as this is probably the most loved build on JC and has been for a long while now haha
     
  6. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
  7. Hoska91

    Hoska91 Formerly 75HJPREM

    Messages:
    244
    Likes Received:
    1
    Trophy Points:
    18
    Joined:
    Jun 17, 2010
    Location:
    Perth
    Members Ride:
    Getz Lyfe & E34 Project
    Looks like you missed it :p, nothing some photoshop won't fix, really need to get the posts up :p 1 post for every 50 odd views ?
     
  8. Dirbatua

    Dirbatua AWOL!

    Messages:
    3,832
    Likes Received:
    36
    Trophy Points:
    48
    Joined:
    Apr 6, 2003
    Location:
    S/e Victoria
    Members Ride:
    VX SS Manual, VX SS Auto, VU SS Auto
    i'll assume your **** faced now which is why there is no photos with the chrome trims on the wheel arches and the masking tape off the front :p
     
  9. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,264
    Likes Received:
    6,678
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    Nice work looks great
     
  10. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
  11. MEESEN

    MEESEN "SOON"

    Messages:
    277
    Likes Received:
    3
    Trophy Points:
    16
    Joined:
    Jun 9, 2010
    Location:
    Geelong
    Members Ride:
    '03 VY
    Wow well done... alot of hours in that but must be worth it now :spot on:
     
  12. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
    not quite yet. still has little bugs that are popping as i progressively drive/run/tune. i suppose i should update:

    "finished" the bodywork off. need to put a few more hours of fine tuning into gaps and adjustments, but everything is bolted on and isnt gonna fall off. the transformation from green roof/black body to now is pretty mind blowing. finally all the chrome parts that ive ordered over the years make sense. on the previous build they all looked a bit *meh* but each little thing like wheel arch moulds and center caps on the rims actually POP now. little bit of polish and the whole car looks new. as in: from the showroom. everywhere you look (except the inside) looks new.

    the issues im having:

    fans were set to come on at 88 degrees which was too late. it allowed the coolant to get too hot and then it started spitting it out everywhere. turned them down to 78 degrees now and it *seems* to have got the temps to drop. but whether its a long term fix or not, im not sure. i have two temp sensors in the car, the ECT is in the factory location (under the thermostat) and my dash mounted guage which is in the side of the head. the ECT seems to consistantly read around 10 degrees lower than my dash guage, so the ecu is reading 88 degrees, the dash guage is reading 98 degrees and the car is spitting coolant, so i reckon the ECT sensor may need to be replaced, but for now, dropping the fans on time will do.

    next the speedo cable is pissing out transmission fluid. bit of a worry, NFI how im gonna fix it, its a brand new speedo cable...

    i melted YET ANOTHER FKEN SHIFTER CABLE!!!! man i spent ages routing the cable to its current position before i redid the firewall, everything was perfect. all the areas that went close to the exhast got shielded and it was all fine, till i was sitting in the driveway for about 40 mins tuning and the cars mustve gotten so hot that they melted a section that was exposed, but at least 200mm away... so i didnt notice at first, turned the car off, let it cool for a bit, then went to drive to ryders and it was stuck in park :( i nearly cried... anyway i found the burned bit and figured... if it melted it closed, then itll melt it open again, so started the car, revved the fk out of it for about 10 mins, it melted the cable enough that it freed it up again. turned the car off and kept moving the cable back and forth for a few mins till i was happy it was free again, then wrapped the exposed section in heat shield and now it seems to be working again (although i havnt checked it this morning)

    now onto a BIG bad thing. when i installed the transmission (remember this is just a straight up used and untested trans) there was a horrible grinding/metalling fan kinda noise which ive never heard before that happened when i put my foot on the brake and turned the steering wheel. for this reason i thought it was the power steering pump, since it drives both the brakes and the steering. on checking the pump i found a bit dent in the base and then assumed the turbine inside was hitting the body of the pump. annnyway, that isnt the case. the noise became more and more regular to the point i was able to hear it while idling, and have narrowed it down to somewhere in the trans. i have NO idea what though, because i have never heard this noise before.
    regardless, on the fwy last night the trans didnt shift into OD, so there is an issue there. so i think this w/e (if it isnt too hot) the transmission is gonna come out and im going to swap all the HD stuff from the t700 and replace the 2-3 clutches and whatever else has been cooked in it. toughen up the 4l60e then stick it back in. i dont trust this trans, and if i dont trust it i cant drive it and i fully intend to go to boths cars and coffee on the 10th and yarra valley cruise on the 9th, so it needs to be done asap.

    all guages work well and light up with headlights, but i got a wiring bug in the dash last night. half my dash switched off randomly inc the fuel guage, but if you pull the dash it comes back on, so thatll need to be sussed out.

    the "self locking" nuts that come on the comp-camps roller tip rocker kits are fkn garbage. pretty sure theyre a "one application throw away" because another one has loosened itself off and is tapping like crazy. it did it on the drive to ryders and i didnt have the time or the light to adjust it, so drove it home. hopefully havnt damaged the lifter too much but having it loose. just one more shitty job to do. getting covered in hot oil isnt really fun.

    still need to do something with the boot. ill hit up showbags soon for a serious "chat" and see if he is keen to help :p failing that i can put my old panelling back in. i need to install the amps cos otherwise have no tunes. and i want tunes. cruising is boring for passengers with no tunes. but since i forgot to install the headunit when i installed the dash, its home is gonna be on the floor till i CBF pulling it all to bits again. after seeing the outside looking so fresh and new, im keen to send it off to the trimmer now to get the interior done. a nice beige/tan tuck and roll leather interior would really suit.

    cruise control doesnt work. i dont know why. meh.

    diff is a little whiney on slight throttle applications at 60mph, but meh. its tight and slips both wheels easy enough.

    central locking doesnt seem to have enough oomph to pull all the door locks closed. not sure why it worked perfectly for 3 years, 1 of those years daily driving. weird that all 4 doors stop working at the same time. may be a wiring issue.

    door light doesnt come on anymore. it has no power. again, not sure why.

    on the good side:

    brakes have bedded brilliantly and stop like a mutherfker

    demister blows hot air like nobodies business.

    steering align is a bit off but drives nice on the fwy. id like to get the toe pulled out a bit more so it self centers better, but its not urgent at all.

    fluffy ... is ... TOUGH now. as i was tuning, trying to get a few hits in the 6000rpm cells, was wondering why it wouldnt hit it... then got fed up of little throttle applications so just held my foot down... was sitting on the limiter i forgot it had. ive now bumped that to 6500rpm :D NEVER did that before the injector re-wire. so HUGE THANKS TO DELCOWIZ. would probably have never spotted that fault if it wasnt for him. before it'd struggle over 4500 rpm and if you look at the dyno grap, it caps out at 4700 and just dies:
    [​IMG]

    even in park it behaved the same way. just struggled to get breath over 4500. i had real difficulty getting hits in the 5000rpm cells. now it freely hits the limiter. entering the freeway last night getting a rough 0-100 time just smashed the limiter in 1st and i got all flustered, lost track of my 0-100 times and just focused on not-dying. so i reckon there has been a fair few ponies picked up now. the trans shift points are no good though, it holds the limiter too long before shifting to 2nd so ill have to touch that up once ive fixed the trans.
    ive managed to get the tune running rich in pretty much all the cells (which is making the cats run a lot hotter) so its safe to drive around, its just really hot and not very nice on hot days.

    ive enquired with my tuner about his availability in the new year. no doubt theyll be swamped, but hopefully i wont have to wait too long. be nice to see what fluffy is capable of now.


    anyway, i havnt been a pic whore cos' there is just so damn much to look at. if you guys want pics of anything, just shot and ill make it happen.
     
  13. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
    AHAHA one of my non-car friends talking to one of his car friends about my car:

    100% nailed it.
     
  14. delcowizzid

    delcowizzid on holiday

    Messages:
    6,855
    Likes Received:
    327
    Trophy Points:
    83
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    The coolant gauge port in the head will read 10 higher than under the thermostat. Ide put a new radiator cap on it shouldn't be spewing water till over 120 at least.more timing less heat if it's idling at 10 degrees she probably heat up and low load cruise will nearly take 50degrees of timing in a 454.
     
  15. Wombles

    Wombles Cars cost too much.

    Messages:
    2,064
    Likes Received:
    3
    Trophy Points:
    38
    Joined:
    Oct 28, 2009
    Location:
    Gippsland
    Members Ride:
    '72 LJ Torana, '95 VS Acclaim and V8 wagon
    Ari, does yours have Tissues in the front? Or an area for tissues? Or is this the LHD models only? Large spacing in the rear but tissues in the front...
     
  16. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
  17. Wombles

    Wombles Cars cost too much.

    Messages:
    2,064
    Likes Received:
    3
    Trophy Points:
    38
    Joined:
    Oct 28, 2009
    Location:
    Gippsland
    Members Ride:
    '72 LJ Torana, '95 VS Acclaim and V8 wagon
    I saw a car show with an Impala... Had a tissue box and tray in the front... But was LHD.
     
  18. ari666

    ari666 250,000 hits

    Messages:
    11,829
    Likes Received:
    116
    Trophy Points:
    63
    Joined:
    Mar 10, 2009
    Location:
    melbourne
    Members Ride:
    1966 impala, R32 GTR
  19. HamaTime™

    HamaTime™ VIP Member

    Messages:
    1,805
    Likes Received:
    54
    Trophy Points:
    48
    Joined:
    Feb 17, 2008
    Location:
    Melbourne
    Members Ride:
    VE SSV G8 & RV6 4Runner
    Looks great ari.

    Your happiness with the new paint makes it all worth it :) All coming together nicely!!!

    It's the fruit of your hardwork over all these years! Be proud mate!
     
  20. Wombles

    Wombles Cars cost too much.

    Messages:
    2,064
    Likes Received:
    3
    Trophy Points:
    38
    Joined:
    Oct 28, 2009
    Location:
    Gippsland
    Members Ride:
    '72 LJ Torana, '95 VS Acclaim and V8 wagon
    Saw it on TV. ...
     

Share This Page