Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

My car is a **** box please help

Shannon9983

New Member
Joined
May 25, 2013
Messages
3
Reaction score
0
Points
0
Location
Sydney
Members Ride
Vx executive sedan
Hey everyone,
Just wondering if anyone can help me. I'm trying to get a quote for work I need done on my VX but I need to know what to say to the mechanic so I don't sound like a helpless girl. Also I'm very short of funds and probably won't be able to get all the work done thats needed so maybe you guys can tell me what takes priority? Ok so heres the problems:

1. The car won't start the first time round when the engine is cold. It just makes the noise like its about to start but the battery light comes up and it shuts down and when I try is again straight after it starts fine. (checked the battery and its good)

2. I think the car is over reving, at idle the tacho is at 1 all the time and when driving at like 40km/h it over revs for 2 seconds up to 4 and the car jolts forward a little. Also when it is idle at lights the car shakes and vibrates.

3.The blinkers always make the ticking noise like they are on, the lights aren't on though it just makes the noise.

4. The car is dual fuel but it wont start or run on petrol anymore. It wont start at all if the switch is on petrol and when I try to switch over while driving the car wont excelerate and it stalls.

Please help me! Can you tell me what to say to the mechanic and in what priority I should fix these problems?
Thanks :)
Shannon
 

Tatiana

Administrator
Staff member
Joined
Nov 30, 2003
Messages
2,496
Reaction score
434
Points
83
Location
Land of the free
Members Ride
Equinox LTZ - runs on cocaine
Definitely the indicators are the highest priority.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,273
Reaction score
469
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V

Danielzke

Member
Joined
Feb 6, 2012
Messages
140
Reaction score
1
Points
16
Age
26
Location
Sydney
Members Ride
Commy
Make sure the tail light loom is plugged in. I had the same problem and it was just uncliped abit
 

franklinfrog

Member
Joined
Oct 6, 2009
Messages
581
Reaction score
5
Points
18
Location
Brisbane
Website
www.cheapbrisbanebikes.com
Members Ride
VY SS Wagon 5.7 Auto Wikid Postie Bike
Sounds like you've got a few unrelated issues happening there. Just repair whichever one annoys you most. If you're worried about being ripped off, get a quote done and post back here prices.
 
Joined
May 30, 2012
Messages
41
Reaction score
0
Points
6
Location
Melbourne
Members Ride
VT Calais V6
2. Check vacuum hoses for leaks/splitting or having come off. Replace as necessary.

3. Indicator stalk off eBay can be purchased for $15 - 100 and is a straight forward swap.

4. Sounds like your fuel pump has died. Quite common and a replacement can be bought around $100 mark give or take.
 

Cashman_309

Member
Joined
Jul 11, 2011
Messages
418
Reaction score
2
Points
18
Location
Victoria
Members Ride
VTII Calais
As Chuck said, your fuelpump in all likeliness is dead due to being run on lpg constantly for too long.
Your rev and idle problem sounds pretty serious to me.
See if you can get any fault codes with a diagnostic tool/scan tool, no point trying to diagnose further until you have done this or your pissing in the wind... financially speaking.
 

Shannon9983

New Member
Joined
May 25, 2013
Messages
3
Reaction score
0
Points
0
Location
Sydney
Members Ride
Vx executive sedan
Thanks for all the info people! Muchly appreciated.
 

GKW

Donating Member
Joined
Jul 7, 2009
Messages
277
Reaction score
1
Points
18
Location
Sydney
Members Ride
2008 VE SSV & 1999 VT SS SII
Where abouts in Sydney are you? Maybe someone here can recommend a good mechanic in your area who can fix your issues.
 
Top