Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

My Holden commodore isn't starting

quinton77

New Member
Joined
May 20, 2019
Messages
1
Reaction score
0
Points
1
Age
28
Location
india
Members Ride
VL Calais Turbo
Hello everyone,

So here's what I know, I was driving and it was blurting and gargling and it ran out of fuel, now it's turning over but not starting. Leading up to today it would turn over and start up before occasionally dying out, but would always start with some revs.

I've tried jump starting it after refueling it and I've gotten the same result, all I hear when turning the key is the fuel pump clicking and the engine turning over.

I'm not really a car person per-say as I only know the basics but I'd appreciate any help, thankyou
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
15,649
Reaction score
9,408
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Fairly common for the CAS to fail in these.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
15,649
Reaction score
9,408
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Just reread, fuel pump clicking? Yeah like Lex said swap the relay. If that doesn't help fuel pump is probably fucked. Try tapping the tank with a broom handle while someone turns the key. If it starts with a tap then definitely a pump issue.
 
Top