Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

MyLink defaults to USB

Discussion in 'VF Holden Commodore (2013 - 2017)' started by MagpieSteve, Jan 16, 2020.

  1. MagpieSteve

    MagpieSteve New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Jan 16, 2020
    Location:
    Melbourne
    Members Ride:
    Commodore VF II MY17 SV6
    Hi
    Maybe this is normal but I can't see why.
    Each time I start the car MyLink will start on the radio (as that is what I last listened to) and then after a few seconds default to the USB.
    I don't want this to happen.
    I want it to stay on whatever I last used (in this case the radio).
    I can't seem to find how to do this.
    Surely I don't need to remove the USB?
    Am I missing some setting or is this just something I'll have to put up with?
    Thanks.
     
  2. stooge

    stooge Well-Known Member

    Messages:
    762
    Likes Received:
    394
    Trophy Points:
    63
    Joined:
    Apr 3, 2014
    Location:
    wa
    Members Ride:
    VF SSV
    it should remember radio or usb but i found it wont remember bluetooth audio.

    the usb stick might be dodgy and mounting late causing the mylink to think you just inserted it which will cause it to jump to the usb source.
    test with a different type/brand usb stick and see if it happens or maybe you might need a software update for the mylink.
     
  3. Philmecrackun

    Philmecrackun Active Member

    Messages:
    152
    Likes Received:
    26
    Trophy Points:
    28
    Joined:
    Apr 10, 2013
    Location:
    Lismore
    Members Ride:
    VFII Calais V 6.2L 1972 Ford Galaxie Wagon 400ci
    Mylink has a mind of it's own, I have mine on shuffle with USB, it plays the same songs out of 1000 or next time I get in the car it is not from where I turned off, or will be the radio. There are no playlists, cleared the lists, swapped USB and still the same.
     
  4. mpower

    mpower Well-Known Member

    Messages:
    3,575
    Likes Received:
    456
    Trophy Points:
    83
    Joined:
    Jan 22, 2007
    Location:
    Brisbane
    Members Ride:
    V2 CV8 Monaro and VF SSV Redline
    maybe it's missing a software update?
     
  5. Geoff6666

    Geoff6666 Active Member

    Messages:
    133
    Likes Received:
    57
    Trophy Points:
    28
    Joined:
    Oct 11, 2016
    Location:
    Killarney Vale NSW
    Members Ride:
    Vf 1 SSV UTE 6M Phantom
    I have an old iPod I use for my music. It's connected through the USB port. My link normally starts where it was last used. But if the car hasn't been used for a few days it will go to the USB. I think this is caused by the iPod battery going flat and when it then gets charged by the car it then switches on and Mylink sees it and connects.I haven't used a memory stick, so not sure how that would work.
     
  6. Anthony121

    Anthony121 Well-Known Member

    Messages:
    1,158
    Likes Received:
    586
    Trophy Points:
    113
    Joined:
    Apr 1, 2014
    Location:
    Melbourne
    Members Ride:
    VF SSV Redline MY17 & VF Director
    I would say faulty memory stick as Stooge suggested. The radio should start if that was the last audio playing when leaving the car.

    As for playing different music once entering the car, I have two VF's and one always remembers the track and the other plays in between the last song depending how I enter the car. The random thing happened on my first VF too. I have the same USB in each car and same music copied from the computer directory. Also looked the keys for the car as I was told there was a main key determined the song was last playing.
     
  7. BlackVXGTS

    BlackVXGTS Well-Known Member

    Messages:
    3,529
    Likes Received:
    526
    Trophy Points:
    113
    Joined:
    Aug 14, 2004
    Location:
    Melbourne, SE
    Members Ride:
    GEN-F2 GTS A6, VS Clubsport 185 A4
    I notice on my Gen-F2 GTS that it will switch from FM radio to USB if I close the console lid cover and sometimes when I use the horn. Obviously something wrong there, but it hasn't bothered me enough yet to warrant tracking down the problem.
     
  8. Skylarking

    Skylarking Well-Known Member

    Messages:
    2,225
    Likes Received:
    962
    Trophy Points:
    113
    Joined:
    Feb 3, 2018
    Location:
    Downunder
    Members Ride:
    Commodore Motorsport
    I have two identical looking keys which I probably used interchangeably and probably explains the early MyLink shenanigans.

    Any way to determine via MyLink which is the main key and which is the secondary key?
    How does one clear customisation and memory for either or both the master and secondary keys?
     
  9. stooge

    stooge Well-Known Member

    Messages:
    762
    Likes Received:
    394
    Trophy Points:
    63
    Joined:
    Apr 3, 2014
    Location:
    wa
    Members Ride:
    VF SSV
    If you have personalization by driver enabled the settings will be different depending on which key you use and remote start will have its own settings.

    I always disable it when getting into a new vf.
     
    Skylarking likes this.
  10. Skylarking

    Skylarking Well-Known Member

    Messages:
    2,225
    Likes Received:
    962
    Trophy Points:
    113
    Joined:
    Feb 3, 2018
    Location:
    Downunder
    Members Ride:
    Commodore Motorsport
    Will disabling clear personalisation data for both keys? And again an I determine which key is which?
     
  11. stooge

    stooge Well-Known Member

    Messages:
    762
    Likes Received:
    394
    Trophy Points:
    63
    Joined:
    Apr 3, 2014
    Location:
    wa
    Members Ride:
    VF SSV
    i am not sure because i only ever disable it lol but even with it disabled the remote start gives me a different setting than the one if i manually start it.
     
    Skylarking likes this.
  12. Z31na

    Z31na Member

    Messages:
    56
    Likes Received:
    16
    Trophy Points:
    8
    Joined:
    Aug 20, 2017
    Location:
    Victoria
    Members Ride:
    2013 VF Commodore Evoke
    I think which settings it loads depends on which key unlocked the car. I had the key that I use everyday on me when I turned personalisation off. It saved the key data from my everyday key and forgot all the default settings saved to the new spare key I had recently had cut.

    edit: Wont need it for this settings but An automotive lock smith can tell you which number each key is. My every day key is 3 and the new spare is 4. First two were lost during the cars first life at Vicpol.
     
    Skylarking likes this.
  13. Dirty Harry

    Dirty Harry Active Member

    Messages:
    196
    Likes Received:
    93
    Trophy Points:
    28
    Joined:
    Jan 13, 2017
    Location:
    Canberra
    Members Ride:
    VF MY17 Series 2 Redline - Red Hot
    mine is a bit wonky too.

    if i start the car, sometimes it is on the radio which was what I last had it on. Other times it might jump to USB and start there.

    Other times if I am listening to a particular album off the USB, it starts on a different album next time I start the car.

    Then the next time I start the car it jumps back to the original album i was listening too.

    All up. I give up. I can't work it out.
     
    Adza75 and Philmecrackun like this.
  14. Forg

    Forg Well-Known Member

    Messages:
    3,306
    Likes Received:
    1,164
    Trophy Points:
    113
    Joined:
    Jun 16, 2015
    Location:
    Sydney
    Members Ride:
    Regal Peackock VF SS-V Redline Wagoon
    I’m the same about it ... except, since the better-half lost her key-fob & we’re both using mine, it’s now 100% consistent & always starts-up playing the same stuff it was playing when I turn the car off (except for Bluetooth - it disconnects when I turn the sound-system off, so won’t restart on Bluetooth).
     
  15. stooge

    stooge Well-Known Member

    Messages:
    762
    Likes Received:
    394
    Trophy Points:
    63
    Joined:
    Apr 3, 2014
    Location:
    wa
    Members Ride:
    VF SSV
    Try disable personalization by driver in the vehicle settings and see how you go.
     
  16. Adza75

    Adza75 Active Member

    Messages:
    416
    Likes Received:
    53
    Trophy Points:
    28
    Joined:
    Sep 15, 2007
    Location:
    Canberra
    Members Ride:
    VFII SSV Redline
    It has a mind of its own. I have only ever used the same fob for 4 years and seen it all. Seems to have 2 different playlists... but its random as to which one it picks. USB will often start up late like the OP says... it's not the USB as I've tried several, all brand new and they all do it.

    It's just MyLink.
     
  17. stooge

    stooge Well-Known Member

    Messages:
    762
    Likes Received:
    394
    Trophy Points:
    63
    Joined:
    Apr 3, 2014
    Location:
    wa
    Members Ride:
    VF SSV
    I noticed the same thing but once i disabled the personalization by driver crap it all settled down and i have been through 5 vf commodores and disabling that crap solved the issue for me on all of them.

    The only difference i have is between the remote start and manual start functions.
     
  18. Adza75

    Adza75 Active Member

    Messages:
    416
    Likes Received:
    53
    Trophy Points:
    28
    Joined:
    Sep 15, 2007
    Location:
    Canberra
    Members Ride:
    VFII SSV Redline
    Mine's been disabled since day 1... I'm the only driver so wanted to set it once regardless of the key I picked up.
     
  19. stooge

    stooge Well-Known Member

    Messages:
    762
    Likes Received:
    394
    Trophy Points:
    63
    Joined:
    Apr 3, 2014
    Location:
    wa
    Members Ride:
    VF SSV
  20. Adza75

    Adza75 Active Member

    Messages:
    416
    Likes Received:
    53
    Trophy Points:
    28
    Joined:
    Sep 15, 2007
    Location:
    Canberra
    Members Ride:
    VFII SSV Redline
    I also only use 1 key... in fact I think the battery has gone flat in the spare. I don't have remote start as mine is a vroom vroom manual ;-) I've used multiple sticks, including the Sandisk. All have the same behaviour. Doesn't worry me now.
     

Share This Page