Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

need help

meki

New Member
Joined
Mar 3, 2011
Messages
7
Reaction score
0
Points
0
Age
32
Location
N.T
Members Ride
Vt commordor gen 3
just bought a vt which has been sitting at a wreckers for 7 years with a blown clutch... wat things to check n do.? only reason why i got it coz the body was ok and want to transfer off my old vt to the one i bought,.... are there any ideas what i should be checking up on? it starts but a orange engine light comes on then goes off.... cheers
 

locolatino

New Member
Joined
Jan 23, 2011
Messages
53
Reaction score
0
Points
0
Location
sydney
Members Ride
2002 Vx II Spac Commodore/ 3.6L V6
send it to a mechanic to get a whole bumper to bumper check and get a full look over! then off those results go from there!
 

graham7773

Active Member
Joined
Oct 6, 2008
Messages
1,053
Reaction score
15
Points
38
Members Ride
VT Acclaim Wagon
Or put a clutch kit in, change all the oils, filters and flush the brake system. Give the car a full service, plugs, leads etc and take it for a drive. you will probably find that the brakes need attention also. 7 years? Serpentine belt would need to be replaced too. while the belt is off look at the pullies. Flush the cooling system and put new coolant in. Once you have it running, check all rubber fuel and brake lines for leaks. The light you mention is probably the oil pressure sensor. 7 years is a long time to sit doing nothing. Hope it works out.
 
Top