Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

No Oxy Sensor! on my Vacationer

BigOne

New Member
Joined
May 8, 2009
Messages
11
Reaction score
0
Points
0
Location
Christchurch, NZ
Members Ride
VL vacationer 3.0l
Hi, I'm new to the board.
We've had a 3l VL vacationer for 17 yrs, from near new, and recently it started giving a bit of trouble, during the warm-up period.
So I did some reading, had a look, and there is NO oxy sensor. It's never had one, as far as I can tell. There is a steel plug in the manifold, and a spare/vacant wiring connector.
WE bought the car near new, so if it ever had one, it was gone when we bought it. Should I get one fitted, and tuned to suit? How much would I expect to pay for an oxy sensor?
 

SweetWagon

booosted
Joined
Jan 27, 2006
Messages
2,139
Reaction score
18
Points
38
Age
32
Location
Springwood NSW
Members Ride
VS Berlina Wagon Supercharged
Hi, I'm new to the board.
We've had a 3l VL vacationer for 17 yrs, from near new, and recently it started giving a bit of trouble, during the warm-up period.
So I did some reading, had a look, and there is NO oxy sensor. It's never had one, as far as I can tell. There is a steel plug in the manifold, and a spare/vacant wiring connector.
WE bought the car near new, so if it ever had one, it was gone when we bought it. Should I get one fitted, and tuned to suit? How much would I expect to pay for an oxy sensor?
NZ does not have to pass the same emissions as Australia, hence the absence of oxy sensor and possibly cat converter. They are tuned to run without an oxy sensor so i wouldn't bother adding one now, your running issues lie somewhere else I'm afraid.
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,993
Reaction score
433
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
as above we kiwis still had leaded fuel so we didnt get cats and O2 sensors.even if you put one in it wont do anything without being enabled in the tune on the chip in the ECU.
 

BigOne

New Member
Joined
May 8, 2009
Messages
11
Reaction score
0
Points
0
Location
Christchurch, NZ
Members Ride
VL vacationer 3.0l
thanks very much for that.
I'll take a look at the AFM next.
 

jatsvl

NEEDS MORE POWER!
Joined
Nov 21, 2006
Messages
959
Reaction score
16
Points
0
Location
Adelaide
Members Ride
vl exec wagon
turbo and 2.0 litre N.Z. models have a detonation sensor.
 
Top