Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

[308] Not running like it used to

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
Ok.

Now that we've got the monaro near completion, we're trying to fine tune it back to it's optimum power.

Dad reckons that it's not making much power compared to what it used to. It's also just hitting a complete wall whenever we get to 5500RPM. Dad said it used to rev out to about 7000.

We're not really sure what it is.

The car has an electronic ignition setup too

We've tried adjusting timing around. We've used a base timing of 2ºBTDC, 6ºBTDC and 7ºBTDC. Should we try another problem, or is it something else?
 

leigh 7005

New Member
Joined
Jan 31, 2009
Messages
492
Reaction score
2
Points
0
Location
adelaide
Members Ride
vb sle
plugs,coil,leads,7000rpm in a 308 thats a bit much unless its a monster motor my 253 dies off at about 5500 and there a lot higher reving engine
 

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
Plugs and Leads are new.

Coil is what we have suspicions of, aswell as the dizzy, but we'd like to know a way that's easily diagnosable to find which one it is.

It's not a stock standard motor, it does have a cam in it.

But it feels like it's just hitting a wall at 5500RPM. Dad said he used to be able to get it to 6500RPM and it was quite comfortable (Apart from the noise), and 7000RPM with just a little pushing.
 

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
It's the exact same as it used to be. The carby is IDENTICAL to what it was years ago.

So the jets shouldn't be a problem.
 

DANNY8

Yo Coooornflake!
Joined
Apr 13, 2004
Messages
2,257
Reaction score
25
Points
48
Age
33
Location
Port Pirie, South Australia
Website
www.kerrbrosracing.com
Members Ride
VK WAGZ 5.0L, GQ Patrol TD42
Stale fuel? Or u got new gear in it? :p

If it's the same carby, maybe rubbers and seals have perished.
 

H1GHROLLR

CHEMICALLY SUPERCHARGED
Joined
Feb 18, 2009
Messages
744
Reaction score
2
Points
0
Location
ROCKINGHAM,PERTH
Members Ride
VX CLUBSPORT R8 LS1
7000rpm is big revs for that motor whats done to it
 

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
Carby got cleaned before it started.
It's done around 2000kms since first startup about a year ago.

It's got a 1/4 Race Cam in it (Don't know the specs, that's all I got from dad)
20thou over pistons
Stage 5 Heads. CC-Rated.

That's all I know from memory.

But I've spoken to Greenfoam about it, and after a while, he suggested that it's damn near definitely the coil
 

leigh 7005

New Member
Joined
Jan 31, 2009
Messages
492
Reaction score
2
Points
0
Location
adelaide
Members Ride
vb sle
did greenfoam tell you how to check the coil? also dose your distributor have vac advance? is it working vkberlina told me how to check and i know mines farked ifn you can suck trough it its stuffed. got any pictures of this beast?
 
Top