Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Oil light issues in a VS V8

beatit

New Member
Joined
Sep 4, 2006
Messages
6
Reaction score
0
Points
0
Members Ride
VS V8
Fellow formites,

I am a new member/poster and was unable to find this problem in the search facilities - so any help is appreciated.

Being a born again DIY mechanic I am tackling things beyond the normal servicing requirements for my VS. I think it is character building when those bloody computers and all things electrical get so complicated. The current assignment thrust upon me is courtesy of the oil light coming on intermittently. The oil level is OK and I thought that it only leaves a couple of options like the wiring, pressure switch or the pump. My wife drove it to work this morning and it was ok until she stopped at a red light when it came on - placing it in park made the light go off, so I was thinking that maybe the idle speed when in gear maybe to low.

Kind regards:bang:
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
If water gets on the oil pressure sensor - maybe thru degreasing or whatever, then there is a good chance that it will intermittently play up. So unless the car is high mileage - like 300K plus, then you should be able to rule out low oil pressure being the culprit....unless the car is overdue for a service and the oil filter is blocked. New sensors are pretty cheap I think so that would be first port of call.
Setting the idle speed is not easy and I'd go down that path as a last resort.
Go for the simple things first! Good Luck.
 

greenfoam

New Member
Joined
Jan 13, 2005
Messages
7,902
Reaction score
126
Points
0
Age
100
Members Ride
VP Executive R-spec
There's a good but unhappy chance that the oil pickup is blocked with old oil and carbon :|, it happens alot with this model and the 5 liter, but swap the filter and oil first to be sure. When I first got my car it threw an oil light at me but I've just be slowly cleaning the motor out by changing the oil often and runnning a bit of oil flush in it before every oil change. No more oil lights for me but I don't think mine was too bad to begin with
 

beatit

New Member
Joined
Sep 4, 2006
Messages
6
Reaction score
0
Points
0
Members Ride
VS V8
Some feedback guys, changed the oil (looked OK and full volume), changed the filter (also looked OK but seemed a little heavy after I emptied the oil - so could have been blocked), changed the oil pressure sender (could only get original part but at $22-80 wasn't too exe) and the problem seems to be gone for now.

Kind regards and thanks:thumbsup:
 

dirt drifter

white trash hillbillie
Joined
Apr 19, 2009
Messages
523
Reaction score
1
Points
18
Location
massive hole in the ground
Members Ride
VS 5L M6 VS 6L M6
thats a fair thread dig but anyway, its on the oil pump housing, bottom front passenger side of motor, near the filter
 
Top