Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Oil or not

freeway29

Member
Joined
Sep 24, 2010
Messages
66
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VS Commodore Excutive
First thing in morning start my VS ecotech V6 up and get a noise like tappets or something last only about 15 seconds, the car has done 260,000 and goes great and im using NULON 15-40 OIL so is the iol or what thanks.
 

VR028

New Member
Joined
Jun 25, 2010
Messages
191
Reaction score
2
Points
0
Location
VIC
Members Ride
VXII SS
i always thought it was normal for the 1st few seconds. my car did that for a few minutes so i used nulon lifter free and it fixed it right up. only makes noise for about 5-10 seconds now. maybe give that a go
 

FstStig

Diagnostician
Joined
Sep 17, 2008
Messages
1,140
Reaction score
12
Points
38
Age
31
Location
Central Coast, NSW
Members Ride
2010 VE SV6
Should be using 20w-50.
 

deanos70

Member
Joined
Mar 6, 2008
Messages
414
Reaction score
5
Points
18
ive been using 20-50 and get a bit of a rattle at start up
was thinking of switching to 10-50 for better flow at start up
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
93
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
I use penrite HPR15 which is a semi synthetic 15W-60 oil,Its a bit thinner at cold startup for better flow,but also stays a bit thicker at high temps for better protection in our hot aussie summers....
 

freeway29

Member
Joined
Sep 24, 2010
Messages
66
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VS Commodore Excutive
I use penrite HPR15 which is a semi synthetic 15W-60 oil,Its a bit thinner at cold startup for better flow,but also stays a bit thicker at high temps for better protection in our hot aussie summers....
thanks for all the info people
 

deanos70

Member
Joined
Mar 6, 2008
Messages
414
Reaction score
5
Points
18
I use penrite HPR15 which is a semi synthetic 15W-60 oil,Its a bit thinner at cold startup for better flow,but also stays a bit thicker at high temps for better protection in our hot aussie summers....
i saw that on their site as well
think i might grab some on the weekend and give it a try
cheers
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
93
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
Ive used it for a couple of years now,and its good oil..And its not too expensive.Id really like to use a full synthetic oil like mobil 1,but its just too expensive for me to buy regularly..I change my oil and filter every 5000 k's.
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,993
Reaction score
439
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
change brand of filter ryco's and another brand the anti drain back valves have issues and cause rattle on startup due to the filter emptying overnight
 

deanos70

Member
Joined
Mar 6, 2008
Messages
414
Reaction score
5
Points
18
delco i have been using ryco
any brand in particular you would recomend
 
Top