Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

On the verge of pulling my hair out!!!

J

jayderichards

Guest
Lately, l have been trying to work on the VK.... Cleaning up battery terminals, checking water, oil, installing a new grill, etc when "Ozzy" finally snapped her bonnet cable and has since refused to open.

I've searched the forums high and low in hope to find a solution that works, but unfortnately, nothing as yet. I have tried removing the grill and getting it up like that. I have sprayed the latch with lubricant, but still nothing.

I've tried pulling on the bonnet cable (as it's snapped by the release handle inside the car) with my other half pushing down on the bonnet...

Argh! im at my ropes end!!!

I think l may have to send Ozzy to the smash repairs for them to have a crack at her.

I'm open to any suggestions that could possibly help!

Jayde
 

vkberlina

VK Madman
Joined
Mar 12, 2004
Messages
3,518
Reaction score
43
Points
48
Age
42
Location
NSW Central Coast
Website
www.members.westnet.com.au
Members Ride
VK EFI 5L, VK 134 Pack, LX8 Adventra, MF35 & MF50b
Yup I have a real easy way for you :)

Get a big straight bladed screw driver & undo your bonnet latchthrough your radiator support.
You will need to have your grille removed for that one.

cheers
Scott
 

Commynist

New Member
Joined
Mar 9, 2005
Messages
21
Reaction score
1
Points
0
Age
40
Members Ride
Vh SL/E commodore
not sure about vk's but with vh's you cant really remove the grill without the bonnet up, so like vkberlina has said get a large, long flatblade screwdriver and turn out the spring loaded catch from underneath the car, through the rad support.
It can be quite difficult to move initailly under the spring pressure so be careful not to burr over the screwdriver slot!
And then dont forget to adjust/ replace your bonnet cable!
 
J

jayderichards

Guest
thanks scott... l'll have to try that tomorrow.

I did take off my grill and try to undo the screw quickly before l went to work.

Much Apprechiate the suggestion guys!
I'll let you know how l go!

Jayde
 

DANNY8

Yo Coooornflake!
Joined
Apr 13, 2004
Messages
2,257
Reaction score
25
Points
48
Age
34
Location
Port Pirie, South Australia
Website
www.kerrbrosracing.com
Members Ride
VK WAGZ 5.0L, GQ Patrol TD42
I had the same thing happen.....was sittin over the pit, had just removed the oil filter and drained the oil to give it an oil change, then I went to open the bonnet....SNAP!

My mate end up getting it tho, not sure exactly how he did it coz he was jamming a screwdriver in my grill and all I could think about was the paint he was chipping off of it.....grrr.

That reminds me I still need to fix that. Instead of fixing it, we just chopped the cable even shorter and relocated it to sit in the tray in front of the radiator, so if I need to open my bonnet I have to bend down and get the cable then pull it from the front......can be embarrassing sometimes haha......especially when ya get pulled over and the cop wants to see under the bonnet haha.....lucky I got a good cop, coz there was quiet a bit of stuff which he could of got me for which would mean it would have to go through regency.....but he just chucked some of the minor stuff on there so it wouldn't have to go. So thankfully it's just a local defect.
 
J

jayderichards

Guest
I GOT IT!!!

My other half and l were trying to loosen the screw as mentioned above, when my other half was able to get hold of the bonnet cable and pull... it popped like a glove!! little bastard that it is....

Thanks guys for your help!! much apprechiated!!!
 
Top