Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Overheating Warning Light Keeps Coming On When Cold

seraphic06

Woodgrain Nut
Joined
Sep 30, 2008
Messages
477
Reaction score
1
Points
18
Location
Adelaide, SA
Members Ride
VZ Berlina Wagon, VS Caprice Series II 5.0
The overheating warning light keeps coming on as well as the warning chime. This would be great if my car was actually overheating but it's fine. I leave the car overnight and start it in the morning and it comes on again. The guage reads it as being cold. It used to be only intermittant but now it seems to be doing it all the time. What could be the problem?

Prior to this happening I had changed all the hoses, the thermostat, radiator cap, the water pump and the radiator itself in order to track down a overheating problem that I WAS having. That has now been fixed. I have cleaned the single cable that goes to near the thermostat housing as well as the dual cable that is on the right hand side. What else could it be?

I have a level 3 dash cluster installed.

I have checked the codes and none are being recorded.

Any ideas?
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Try a new sensor I'd reckon. Not sure if there is a test but I'll look.

Edit...there is a test in Gregorys involving suspending the sensor in water and heating it whilst noting the electrical resistance with a multimeter.....
e.g. at 30C 2.268 k ohms
at 100C .180 k ohms
 
Last edited:

seraphic06

Woodgrain Nut
Joined
Sep 30, 2008
Messages
477
Reaction score
1
Points
18
Location
Adelaide, SA
Members Ride
VZ Berlina Wagon, VS Caprice Series II 5.0
I happen to have a spare one. I have just changed it over. Let's see how it goes.
 

seraphic06

Woodgrain Nut
Joined
Sep 30, 2008
Messages
477
Reaction score
1
Points
18
Location
Adelaide, SA
Members Ride
VZ Berlina Wagon, VS Caprice Series II 5.0
The replacement sensor seems to have done the trick. Thanks Hako.
 
Top