Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Petrol warning light staying on???

67wogval

New Member
Joined
Nov 8, 2009
Messages
94
Reaction score
2
Points
0
Location
west suburbs, melb
Members Ride
vz commodore
Hi recently i changed a couple of globes in my vr berlina dash cluster, and im am 100 % positive i put the dash back together proparly, but now it has a problem of the low petrol warning light which comes on always within a minute of starting the car, even though it has plenty of petrol, and its reading correct on the petrol guage, so im sure its not a stuck float in the tank if its reading correct on the fuel guage. I have disconnected the battery to try and reset computer but it still does it. So is there a sensor on the tank or something? What could be doing this?
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
I'd remove the dash again and triple check the work you did - do this with the battery disconnected. It is too much of a coincidence for the fuel light to fail at the same time as you replaced bulbs.
 

67wogval

New Member
Joined
Nov 8, 2009
Messages
94
Reaction score
2
Points
0
Location
west suburbs, melb
Members Ride
vz commodore
I hear ya mate, and i took it out 3 times and checked all the wiring ect....you cant stuff it up, all the plugs can only go in 1 way. But its still doing this
 

Skrewdriver

New Member
Joined
Feb 23, 2011
Messages
47
Reaction score
0
Points
0
Location
Brisbane
Members Ride
vs commodore
is car dual fuel? if mines running on lpg,the petrol light comes on and makes a warning beep approx 20-30 seconds after start-up,cos its not detecting petrol
 

67wogval

New Member
Joined
Nov 8, 2009
Messages
94
Reaction score
2
Points
0
Location
west suburbs, melb
Members Ride
vz commodore
No car is on straight petrol only, it always does it 20 to 30 seconds after starting the car, even when u fill it up, shows on the petrol guage that there is plenty of fuel in tank, but still it beeps. I have not fixed this yet, i think it must be a fuel sensor or something.
 
Top