Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Power lost while driving

Cmeb south

New Member
Joined
Nov 19, 2017
Messages
3
Reaction score
0
Points
1
Age
37
Location
Adelaide
Members Ride
Vy executive
2002 vy exec auto sedan. So driving home this morning car was all fine.... went to pull into servo and car lost power steering and just came to a stop... battery light came up on dash but everything else was off. Turned key off and then re started and it was fine but i only drove it to park out of the way. Called raa as i didnt wanna drive it and he did all his checks for battery and alt and said all is fine. Battery is only 6mths old... he said alternator was fine and charging. He put it down to a charging system fault but nothing more specific and gave me a deferred tow for if it happens again..... so does anyone know if this is a one off or likely to keep happening or di i just take to mechanic and see how much its gonna cost depending on what they do or think its is any advice much appreciated thanx
 

rambunctious

Well-Known Member
Joined
Jun 9, 2011
Messages
1,846
Reaction score
652
Points
113
Location
Alexandra Headland Qld
Members Ride
VZ Executive Wagon and VZ Ute
Stay away from mechanics as long as you can.
They will do no more than the raa but charge more.
Battery is 6 months old so I assume it has a bright green light in the charge window on top of the battery.
Have it tested by the place you got it from if possible.

If it stopped as you were turning it may be a body earth.
I would be disconnecting the battery then redoing the body earths.

By redoing I would unbolt/unscrew the earths from the body and sand paper/scratch the body and earth fitting then refit, meaning make them as clean/shiny metal as you can before refitting.

Another thing that seems to be a problem is the crank angle sensor.

Another thing people seem to have trouble with is the key remote if it is old and tired.
 

Cmeb south

New Member
Joined
Nov 19, 2017
Messages
3
Reaction score
0
Points
1
Age
37
Location
Adelaide
Members Ride
Vy executive
Stay away from mechanics as long as you can.
They will do no more than the raa but charge more.
Battery is 6 months old so I assume it has a bright green light in the charge window on top of the battery.
Have it tested by the place you got it from if possible.

If it stopped as you were turning it may be a body earth.
I would be disconnecting the battery then redoing the body earths.

By redoing I would unbolt/unscrew the earths from the body and sand paper/scratch the body and earth fitting then refit, meaning make them as clean/shiny metal as you can before refitting.

Another thing that seems to be a problem is the crank angle sensor.

Another thing people seem to have trouble with is the key remote if it is old and tired.
Thanx for that.... the battery was from the raa when the old one died... key should be fine cause thats newer than the battery lol i will try the earths but yeah i wanted to steer clear of mechanics as i think they will just do bits n peices trying to figure it out while charging top dollar!! Also had new sparks n leads last service which was early dec, was just freaky loosing power while driving but luckily was aftee i got off expressway. Thanx for the help hopefully it wont be happening again
 
Top