Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

power steering low speed shudder

Discussion in 'VZ Holden Commodore (2004 - 2006)' started by jon_d2, Jul 21, 2006.

  1. jon_d2

    jon_d2 Guest

    I finally had my VZ slow speed turning power steering shudder fixed under warranty.

    Holden have released a new high pressure hose from the pump to the rack. Mine was replaced under current warranty.


    The dealer said the original hose was expanding under the load and causing the shudder.... anyway, who cares, it's finally fixed.

    Don't accept the recommendation to replace the fluid.... I did this and it solved it for about 2 weeks.
     
  2. hkmonaro68

    hkmonaro68 New Member

    Messages:
    165
    Likes Received:
    2
    Trophy Points:
    0
    Joined:
    Mar 27, 2006
    Members Ride:
    vz wagon
    What model and engine is your VZ?
     
  3. jon_d2

    jon_d2 Guest

    series 2 berlina wagon...

    but I understand its a common problem across all VZ's. seems to occur around 60-80k's and when the fluid is hot. (mine was really bad after driving for 30-40 minutes.)
     
  4. Clinster

    Clinster New Member

    Messages:
    114
    Likes Received:
    4
    Trophy Points:
    0
    Joined:
    Dec 19, 2005
    Location:
    SA Nth/Est
    Members Ride:
    VSII Berlina
    Does it happen when you are driving in a straight line or does it happen when you are turning??
     
  5. jon_d2

    jon_d2 Guest

    sorry fellas,

    I just wasn't thinking clearly. It's a VY... :sleeping:
     

Share This Page