Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Power steering reservoir tank leaking through top and over-full

evo33

New Member
Joined
Apr 17, 2009
Messages
3
Reaction score
0
Points
0
Location
Queensland
Website
www.webdivide.com.au
Members Ride
Commodore VR 1994
Hi,

I have the same problem as dawg explained in his post http://forums.justcommodores.com.au/vr-vs-holden-commodore-1993-1997/91703-knock-play-steering.html

Original fault (courtesy of dawg):
When the cars stationary, i quickly turn the steering wheel left, right and it knocks from down the end of the column, seems to have a bit of play. And the other thing is, when i go over bumps and onto driveways when the wheels hit the bump you can really feel the hit through the steering wheel as it jerks it say 5mm around when it hits. Also when im driving at any speed eg say over 60, when going through rough patches on the road, the steering wheel/column vibrates and bounces up an down.


I have replaced my front struts (complete full kit), have replaced tails-shaft, have replaced power steering high pressure hose and still didn't solve the problem $1,500 later.

Originally my 1st rack was under warranty and the faulty rack was leaking. Got a replacement rack and that's when the noise began. 5 mechanics couldn't diagnose the fault after been told a whole bunch of crap to replace other parts which didn't fix the fault and cost me almost more then the car is worth. After finally getting around to getting another replacement rack from Australian Power Steering the leak stopped but a whole new problem began.

That's when I wen't on a spending spree to try to fix the fault not been told that I was given a faulty rack through my warranty!!! After I got another replacement rack under warranty (3rd rack) it was perfect for the first 2000kms with no leaks and no clunking noises.

I moved states, traveled 2,000kms and guess what? the clunking noise has began. The problem is that I get a clunk noise coming from the front and can feel it in the steering wheel and the floor of the car when I drive slowly over bumps and go up or down driveways.

I have discovered that my power steering fluid in the reservoir tank is now actually leaking out from the top outwards - through the main cap which is screwed securley. It's as if there the power steering fluid is not going through the power steering rack now. When I had the 3rd rack fitted I made sure the level of power steering fluid was correct in the reservoir tank. But now after driving from SA to QLD it's close to the top of the lid and seems way to much? I have not added any extra power steering fluid and it puzzles me why the level of the fluid has risen in the reservoir tank?

Does anyone know what the problem could be why I am getting these clunks of sound and now most importantly why the power steering fluid is spilling out of the reservoir tank?

The rack is only 4wks old and has done 2,700kms...

Any help is much appreciated please.

regards,
Adrian.
 

immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
16,932
Reaction score
5,810
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX s2 Calais S/C
when the fluid was coming out of the reservior was it extremly hot?

i'd check to see that the rack is bolted up properly to the K frame and also ensure the intermediate steering wheel shaft has been done up properly
 

evo33

New Member
Joined
Apr 17, 2009
Messages
3
Reaction score
0
Points
0
Location
Queensland
Website
www.webdivide.com.au
Members Ride
Commodore VR 1994
When the fluid was coming out of the reservoir was it extremely hot? I noticed this while driving up to QLD from SA, I would say it would of been hot as it's as if the fluid is overflowing from the reservoir tank.

I have had the car checked out today by Pedders and they did a full analysis of the problem I told them. They checked the power steering rack and it seems all fine with no leaks and they have assured me that it has been properly bolted to the K frame and all the bolts are securely tighten. So they seem to say that there is no problem with the rack or the reservoir tank and they couldn't find any cluncking noise coming from the front!!! They also checked the intermediate steering wheel shaft and say its fine which I also had replaced few weeks ago (which was diagnosed by Pedders in SA).

BUT,

As soon as I drove out of Pedders the noise began again and the clunking sound is still there. It's driving me crazy as no one can find the fault. I would like to also mention that since the noise began when I brake my steering wheel gets the shakes like crazy especially when slowing down from fast speed.

This clunking sound puzzles me as I'm not sure if its causing any damage to my new tyres, new struts or possibly what appears to be a fine power steering rack?

Does anyone know what this could possibly be?
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
88
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Is it possible the reservoir tank was overfilled? Also check the hoses from the reservoir to the pump and return - they may have swollen (they can do this and will block flow of PS fluid).
In my limited experience, clunking as you describe it is usually the result of either worn tierod-ends, rack-ends or excessive play in steering rack pinion. As you are also having vibration problems when braking then also include distorted discs, sticking brake calipers, loose hub bearing to strut bolts for a start.
When you drove out of Pedders and the clunking started again you should have taken it straight back (good in theory I know!)
Good Luck.
 
Top