Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Power Window Regulator Question.

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,354
Reaction score
833
Points
113
Members Ride
Zenki S14
Hey there,

Just saw the other power window question, so I thought it was time to ask. A few months ago, I tried to put my drivers side (power) window up. Anyway, it was really struggling, then all of a sudden there was this loud snap, and the window then fell through the door. When I took the regulator out, one of the regulator arms was bent at pretty much a 90 degree angle.

None of the little white things were broken, none of the regulator teeth were broken. So anyway, I bent the arm back, and put it back in the door. Whilst doing so, I took a nice chunk of my tinting out with the regulator teeth, as they were rubbing up against the window at one stage.

I have a feeling that it is still rubbing up against the window, just, but I have no way to tell. The window also isn't travelling in the bailey channel correctly (it cuts across the rubber and out of the channel).

My question is, is the regulator arm supposed to have some kind of bend in it from factory?

Thanks heaps.
 

hsvpunk

volunteer firefighter
Joined
Jan 1, 2007
Messages
592
Reaction score
20
Points
0
Location
Mornington, Vic
Members Ride
vy ss II M6
Ive fixed my drivers side one on my car, i ended up bending the arm in the same 90 degree angle as you, so i bought another regulator from a local wreckers for $50 bucks.

From factory i dont think it did. (cant remember been a few months since i did mine)

you jsut have to make sure that all the rivets are in place (these rivets are not your normal rivets from bunnings etc.., Holden should have the proper ones in stock) The regualtor arms should sit nicely in the given channels and should be all good.
 

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,354
Reaction score
833
Points
113
Members Ride
Zenki S14
I fixed it by attatching the regulator with bolts (as per the power window conversion guide). I can get three of the holes to align, but not the fourth. It seems like I might have to try and re-align it sometime.
 

hsvpunk

volunteer firefighter
Joined
Jan 1, 2007
Messages
592
Reaction score
20
Points
0
Location
Mornington, Vic
Members Ride
vy ss II M6
jsut try and align it in a different way first, it should all go back in the right way.
I know i tried once or twice to get it working right.

Just make sure that the front (mirror end) of the rail is in its place, as thats what stuffed me up twice, as i couldnt quite see that it hadnt aligned properly.
 

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,354
Reaction score
833
Points
113
Members Ride
Zenki S14
Just make sure that the front (mirror end) of the rail is in its place, as thats what stuffed me up twice, as i couldnt quite see that it hadnt aligned properly.
Thanks for mentioning that, as it is this side that has one unaligned bolt hole, and thus, no bolt. Will try.
 
Top