Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Problem with link pins?

Hudson5163

New Member
Joined
Jan 13, 2011
Messages
1
Reaction score
0
Points
0
Age
33
Location
Armidale
Members Ride
VT Executive
Hey guys,

I've recently had a whole bunch of problems with my VT's link pins as the mechanic I usually go to fitted them incorrectly a couple of times, resulting in the washers breaking, the rubbers splitting and the whole "metal on metal" sound coming back (original problem). After I took it back to him for the third time (he had to pay for each new set, as he fitted the others incorrectly) the car seemed to run fine (no noises). Lately, however, I have begun to hear a very slight sound coming from the same area as the link pins, like washers moving around. The knocking sound is gone, so the washers don't seem broken like they were before. Could something need tightening, perhaps? Does it sound like a slight adjustment could stop the sound? Am I just being particular? Responses would be greatly appreciated.
 

Full Spectrum

Bro it's a VW your Audi!
Joined
Dec 6, 2003
Messages
2,411
Reaction score
15
Points
0
Location
Melbourne
Website
www.news.com.au
Members Ride
Berlina V6
If its the same problem. tell that so called mechanic to replace them with some better after market ones. or get your money back and buy some nolathane ones and fit them yourself.. but in all honesty it could be anything down there. might be tie rod ends inner bushes chassis bushes. anything could be contributing to it. so best bet is find yourself someone that specializes in suspensions only.
 

IBLOWN

Well-Known Member
Joined
Sep 13, 2005
Messages
2,115
Reaction score
34
Points
48
Age
41
Location
Sydney
Members Ride
VS V6 TT/'13 VF Senator/'11 WM CapriceV/Hayabusa
The rattly washery noise will be link pins when you go over rough road.

How do you install link pins wrong? Have to make sure you put the washers on the right way. Cups of the washers out.

Front end should make no noise at all. My wifes VT SS is silent. After replacing every bush in the whole front end lol...
 
Top