Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

RB30 injector problem

Discussion in 'VL Holden Commodore (1986 - 1988)' started by vl_comm, Apr 14, 2009.

Tags:
  1. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    gday, my rb30 injectors are getting power but aren't firing and the EFI relay is all good, thers fuel runing through the rail aswell if any one noes whats goen on pleas help. cheers

    also any 1 wanting to buy a vl rear seat in gook nick pleas ask. cheers

    And any ideas on what i should do with my diff.. i was thingking of welding it so whats the best way to do it?cheers
     
    Last edited: Apr 16, 2009
  2. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
    check the Relay near battery one which is connected up to a diode in the loom (3 relays located here, its the one closest to the overflow reservoir) i have had and still have problems with this relay for quite some time now. Probably just an earth problem.
    check for corrosion on terminals/spade connectors and under the plug not just the relay.
    this relay controls the injectors
     
  3. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    hey cheers, thers only 1 relay ther?
    but i fount a loose wire and re wired it. this wore ran from the relay to the positive terminal on the battery..now she idles on fuel but if ya try rev it it just dies?
     
  4. Goon

    Goon Scientific Tuning

    Messages:
    2,508
    Likes Received:
    9
    Trophy Points:
    0
    Joined:
    Feb 20, 2006
    Location:
    BrisVegas. QLD
    Members Ride:
    VY CUSTOM.
    try this trick...cover ur afm with ur hand for a second while u rev it, might bring it back to normal :whistling
     
  5. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    i would give that a crak but now it just idles really ruff for 3-4secs then dies? and still dies straight away wen ya open the throtle?
     
  6. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
    exactly what u r stating is caused by CAS or AFM malfunctioning
    pull the codes from the ECU


    Code 11 - Crank Angle Sensor circuit
    Code 12 - Air flow Meter circuit
    Code 13 - Coolant Temp Sensor circuit
    Code 14 - Vehicle Speed Sensor circuit
    Code 21 - Ignition Signal circuit
    Code 23 - Trottle Switch circuit
    Code 24 - Neutral Start Switch circuit
    Code 31 - System Pass (OK) (Non A/C), A/C circuit (A/C models)
    Code 32 - Starter Signal circuit
    Code 34 - Knock Sensor cicuit (Turbo)
    Code 44 - System Pass (OK) (A/C models)
     
  7. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    whers the ecu? and "pull them"? are they like fuses or relays i pull out?
    (im new to VLs)
     
    Last edited: Apr 16, 2009
  8. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
    ok
    Behind your passenger side kickpanel is the ECU (Engine Control Unit)
    there is a screw on the side Diognosic Mode Turn this fully clockwise carefully and turn your ignition on
    in the peep hole there is 2 LED's Red and Green
    RED = Tens
    Green = Units
    So if red flashes 2 times then green 3 times that means code 23 Representing Throttle Switch
    press the throttle to cancel this code
    Other codes to cancel is 14 Speed sensor(u can leave it) car needs to go over 10kms to cancel code
    24 Neutral Switch.. Move the gear shifter to Drive then to Neutral and then park to cancel code

    Then keep an eye on further fault codes coming up
    Write down the numbers for us to help u with
    codes are seperated with a slight pause
    Goodluck buddy
     
  9. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    ahh ok
    my comms manual?
    and how do ya choose which code to see?

    or..it only flashes the codes that are playing up?
    cheers
     
  10. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
    it will keep showing these codes in a loop u dont choose the code the code represents the problem the car has and then u can rectify
    Dont worry about the 24 code then tell me the codes u get
     
  11. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    ahh ok sweet il go have a look now.. coz its dark lol
     
  12. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
  13. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    lol nah i live in vic

    ok heres the codes i got
    -12
    -14
    -21
    -23
    -24
    -31
     
  14. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
    Ok man well that would be your Air Flow Meter(AFM)...Very Common on a vl commodore i have had 3 go on me
    have u got a mate with a vl working u can change it over to see it it fixes the problem. Or try one at a wreckers
    Check the AFM Plug wires under the rubber boot for corroded wires Before hand

    The AFM is the black box in the intake piping attached to the Airbox Lid
    c Pic

    Mate i always keep one spare as well as a Crank Angle Sensor(CAS) another common problem
    Dont forget to turn the screw to take it off diognostic mode and ignition off
     

    Attached Files:

    • AFM.jpg
      AFM.jpg
      File size:
      126.7 KB
      Views:
      1,183
  15. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    ahh ok
    in there, there was a wire sensor or sumthing looking loose.. il try get a pic of it tomorow ans chek the wires.
    also its on gas aswell and runs fine on gas is that a problem?
     
  16. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
  17. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    ahh ok just wreckers to get 1?
     
  18. detox_nath83

    detox_nath83 Another VL Driver

    Messages:
    2,160
    Likes Received:
    6
    Trophy Points:
    0
    Joined:
    Aug 6, 2005
    Location:
    Queensland(Sunny Coast)
    Members Ride:
    VL Turbo Commo
    try it first though and keep receipt just incase it was damaged in an accident
    yeah and ring around for cheapest one. anywhere from $40 - $150 depending on the stooge who sells it

    Like i said check the plug under the rubber boot for corrosion

    Goodluck
     
  19. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    thanks for ya help mate il let ya no how she goes cheers
     
  20. vl_comm

    vl_comm New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 13, 2009
    Location:
    New Gisborne,Vic
    Members Ride:
    VL commodore 5sp man/EB falcon 5sp man
    today i added a fue more wires to the wire a found the other day now it runs really really ruff when the throttle is open and idles like normal so do u still think its the AFM?
    cheers
     

Share This Page