Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Rear left and back window roof brake light not working

VEpilot

New Member
Joined
Aug 18, 2017
Messages
8
Reaction score
4
Points
3
Age
38
Location
Perth WA
Members Ride
VE sv6 series 2
hi
Iv recently noticed that my rear left and the roof back window brake light are not working, I thought it was just the bulb at first so I replaced that however the one I pulled out didn’t seem to be broken. That didn’t work and then I noticed the roof brake light was working. The rear right drivers side brake light works fine. Iv checked the fuse under bonnet I think f32 f33 I think it was there fine. Can anyone help befor I go to an expensive auto electric mechanic.
Many thanks in advance
Mark
 

greenacc

Searching for the billion
Joined
Jul 13, 2008
Messages
6,075
Reaction score
1,710
Points
113
Location
Sydney
Members Ride
VE Berlina
Just double check the globes are in correctly. The sockets are pretty average and its easy to twist the globe too far.
I suppose you could move the good globe from the side that is working to the other side as another test. The LED strip lights in the window do fail at some point. Mine lasted about 180,000 ks.
 

Fu Manchu

Septic Tank Pump Operator
Joined
Mar 18, 2006
Messages
10,184
Reaction score
8,559
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
The roof LED is fed power via the roof loom and down the A-pillar, then plugged into the instrument panel assembly near the right tweeter and windscreen.

Could be coincidence.

To replace the LED unit, the roof lining has to be dropped down, the LED assembly uncrewed. (Three Phillips head screws) unplug the connector (fiddly)

The rear is simple, replace the globe.
 
Top