Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Revving/Lagging

DEMONOID88

New Member
Joined
Mar 25, 2009
Messages
5
Reaction score
0
Points
0
Members Ride
1996 VS Executive
Hi all,

I have a VS Executive 1996. Lately (the last few months or so) when I go to put my foot down, usually in the mornings or when it is first driven after being idle for sometime... it revs a lot and sometimes does not take off. it lags. it sounds a lot louder than it usually was, and it feels absolutely weak! sometimes say i'm giving way.. I know I can zip across to the other side with plenty of time, but i put my foot down and it revs loudly and crawls for like 2-5 seconds then shoots off as the speed of light.. its pissing me off and caused me some close calls.

What could it be? Spark plugs.. new, air filter, new, fuel filter.. new.

Occasionally I hear this grinding noise during transmission, at around 2,500RPM(rev thing) but I'm pretty sure this is a different issue.

I left it because the car still moves but now I have enough money I want to get it fixed... wtf is it? My gut feeling tells me that this is going to be very expensive and if that's the case I will just get rid of the POS and get a nice new one.

Thanks.
 

OnLiA6

New Member
Joined
Feb 28, 2009
Messages
12
Reaction score
0
Points
0
Age
33
Location
Bendigo
Members Ride
1995 VS 3.8
might be you auto who knows??? does it only do it wen its cold on first start???
 

love the general

New Member
Joined
Aug 28, 2008
Messages
147
Reaction score
0
Points
0
Members Ride
vy ss ute daily hj gts project
mines doin the same pretty sure its the bands in the transmission mine was doin it a little bit for about the last month but the other day i changed the oil and the filter and its gotten a lot worse since then. My car is booked in for friday so i'll let you know
 

DEMONOID88

New Member
Joined
Mar 25, 2009
Messages
5
Reaction score
0
Points
0
Members Ride
1996 VS Executive
It is not when it is cold.
Generally when you first turn it on. Even if that happens to be a 40degree day.
It will do it for the first 10-20 mins its the worse, then it gets significantly better but not 100% right.

How much is that u think?
 

whitevrboi

Just another white vr.
Joined
Feb 6, 2008
Messages
243
Reaction score
1
Points
0
Members Ride
VR Executive S2
yea i've got a similar problem, hasnt been as bad since i got my exhaust n extractors done but its still there...can u post up how u go at the mechanics?
 

DEMONOID88

New Member
Joined
Mar 25, 2009
Messages
5
Reaction score
0
Points
0
Members Ride
1996 VS Executive
Will do.. well when I book it in.
It's a pain because I have to work 8-4 everyday.
Hate getting the train!! So slow and ***in weird as randoms look at you. Specially at footscray station
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,019
Reaction score
85
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Check you transmission fluid level and hope it is low...otherwise it's a new trans soon. Might be time for another car with the price of 2nd hand cars!!
 

7shane0

New Member
Joined
Mar 24, 2009
Messages
10
Reaction score
0
Points
0
Location
camira
Members Ride
VR commodore sedan
dude even if its like a 40 degree day your engine and transmission are still guna be cold. From what you have mentioned its obviously a tranmission issue so id take it to a transmission shop and get them to check it out. otherwise you shouldnt be driving your car hard when its cold, thats the worst thing u can possibly do besides putting a drift pod filter on...
 

DEMONOID88

New Member
Joined
Mar 25, 2009
Messages
5
Reaction score
0
Points
0
Members Ride
1996 VS Executive
Update
For those who wanted to know how it went.
Took it to a transmission center today, and he drove it and said the transmission is fine. He believes it to be an exhaust problem. There's a rattling noise and a performance drop, and a create fell off a truck and slammed under my car a month ago. That might have screwed something up.

Anyway I will post back when I've taken it to mechanic or exhaust place and let you know how it went. I am so glad my transmission is fine - $1,800+ to fix = HELL NO!

Cheers.
 

XeKToReX

Put it on credit!
Joined
May 9, 2005
Messages
147
Reaction score
1
Points
0
Age
33
Location
N/E Melbourne, VIC
Members Ride
VK SL, VR Exec, VS Stato, VT Clubby #555
this grinding noise only happen under load on a 3-4 shift? Mine seems to grind a little, trans is about 80,000 old, not slipping or anything, I was thinking its messing up when it locks the converter up.. not sure as to what it is..
 
Top