Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

rough idle, miss under 2k rpm

bombadore

New Member
Joined
Jul 14, 2019
Messages
4
Reaction score
0
Points
1
Age
41
Location
newcastl
Members Ride
vy s
hi everyone, i have a really frustrating problem and i hope someone can help me out before i ust rip this engine out and put a new one in.

i have an 04 vy s2 and it idles like crap.

Its idling at 900rpm so thats not too bad but it is a bit shaky, then when you give the pedal a jab it misfires from 900rpm up to about 2000rpm.

i have changed plugs, coils, leads, i found a hose coming out of the throttle body had come off one end, it has good suction so i plugged it back in to what i think has something to do with emissions?

i pulled the cable off the iac (i think) when running, no rpm change.

took the intake house off checked the throttle body, maf sensor etc all good.

took the plenum cover off and there was a little carbon but nothing too thick, back of the throttle body had a bit and i cleaned it out.

new fuel filter.

the miss is only when you give it about 50%+ throttle and down low.

it is doing it in neutral sitting in my driveway revving it, and the engine is shaky idling.

i was thinking about just dropping another engine in it but i know it has to be something simple.

any ideas?
 

bombadore

New Member
Joined
Jul 14, 2019
Messages
4
Reaction score
0
Points
1
Age
41
Location
newcastl
Members Ride
vy s
just took leads off coils one at a time and it seems 2 of the plugs on a coil wont spark, changed coil same problem so i assume its dfi module
 
Top