Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

speaker buzz help

richardpalinkas

Blown Alloytec
Joined
May 4, 2009
Messages
2,290
Reaction score
14
Points
38
Location
Gold Coast
Members Ride
Raptor Impulse VZ SV6
hey i have a problem and cant seem to find anything to help fix it. i just bought a 4 channel amp and hooked up my speakers and now i have a constant buzz only comming from the mid range and tweeters. its always there, and i definately know that its not altenator whine because it happens even when the ignition is off. its like a certain frequency is always distorted sort of sound. someone please help!!!
 

DUK13Y

When in doubt, slide it out
Joined
Nov 4, 2007
Messages
793
Reaction score
5
Points
18
Location
Sydney, Australia
Website
www.facebook.com
Members Ride
VEII SSV, VYII Berlina, '97 Lancer
I have a similar problem with my computer speakers. To me it sounds like a earth fault. Check all your connections and make sure they are clean, ie haven't got any dirt in them giving a faulty connection, you could plug your amp into just some normal speakers outside of the car and test that the unit itself hasn't got a problem.

Could be a million things but I'm guessing a faulty connection somewhere. Maybe take it to a professional fitter and get them to do it; at least that way if there's any drama you have them to blame.
 

richardpalinkas

Blown Alloytec
Joined
May 4, 2009
Messages
2,290
Reaction score
14
Points
38
Location
Gold Coast
Members Ride
Raptor Impulse VZ SV6
yea i tested a comp speaker and it still distorts, and i changed the earth position today and it didnt help at all
 
Top