Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Speedo delay, is this normal?

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,291
Reaction score
6,544
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
I have a 2 -3 second speedo delay when taking off that i have never noticed before. Not sure if this is normal? Anyone else noticed it. Auto trans.
 

deserthead

Well-Known Member
Joined
Oct 20, 2004
Messages
1,078
Reaction score
72
Points
48
Location
Cairns QLD
Members Ride
VS III l67 Column Shift Ute
Could be the voltage reg in the cluster playing up. Dry solder joints. Had fuel and temp gauges needing the old whack to wake them up. Went over all the joints and sorted it. Might be worth a look?
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,291
Reaction score
6,544
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Cheers for that. Might just leave it until it becomes a real problem. Don't want to disturb the old cluster in case i break something.
 

vs-lover

Well-Known Member
Joined
Mar 9, 2013
Messages
2,443
Reaction score
1,590
Points
113
Location
Adelaide
Members Ride
VS S2 Calais, VS S2 Exec Wagon, VS S2 Acclaim
Hi Losh,

This symptom is quite common on these Level 1 & 2 clusters. Two of our VS' have suffered from it already 10 years ago when they were both 90,000km cars and now they have both travelled over 200,000km's and it's still the same, no change.
 

VT&VX

Active Member
Joined
Aug 27, 2017
Messages
738
Reaction score
159
Points
43
Age
87
Location
Brisbane
Members Ride
VX Acclaim
So you are driving a car with a dodgy speedo.
Is this just when you start moving? How do you know if you can rely on the speedo reading when travelling at any speed.
Please say you have a speedo readout on your GPS navigator.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,291
Reaction score
6,544
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Speedo works just fine but takes about 2 seconds to kick in. I have no intention of trying to repair it as i could possibly in end up with a non functioning cluster. In the city i sit along with the traffic and it reads 70 in the 70 zone. Highway it reads 110 at 2000 revs. As for my GPS is doesn't register speed.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,291
Reaction score
6,544
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Just for the record in case anyone was wondering all my tyres are in excellent condition. My brakes could be better but they are as good or better than when it rolled out of the factory. Just a shame VR V6s brakes weren't as good as they maybe could have been.
 

StephenM

Active Member
Joined
Jun 26, 2017
Messages
232
Reaction score
47
Points
28
Age
69
Location
Innot Hot Springs Qld. 4872
Members Ride
VS Equippe Series II
Speedo works just fine but takes about 2 seconds to kick in. I have no intention of trying to repair it as i could possibly in end up with a non functioning cluster. In the city i sit along with the traffic and it reads 70 in the 70 zone. Highway it reads 110 at 2000 revs. As for my GPS is doesn't register speed.
Mine is about 2000 @ 100kph.
 

jeepster

Active Member
Joined
Feb 26, 2010
Messages
230
Reaction score
33
Points
28
Location
WA
Members Ride
VSII Ute
I have a 2 -3 second speedo delay when taking off that i have never noticed before. Not sure if this is normal? Anyone else noticed it. Auto trans.
Yes, old speedos stick and the needle doesn't move until you hit 20, 25, 30 km/h depending how bad it is.
You can get an instrument cluster from wrecker which might have same problem.
Or pull out the cluster when you have blown bulbs, and put some silicone lube on the spindle. Fuel/temperature guages can stick too. I haven't seen a tacho play up yet.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,291
Reaction score
6,544
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Yeah i think its one of those things best left alone until it really needs to come out. Agree most clusters will be the same, unless already overhauled.
 
Top