Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

SRS Fault

vy_berlina03

Member
Joined
Jan 11, 2007
Messages
164
Reaction score
21
Points
18
Location
Liverpool NSW
Members Ride
MY15 SV6 Storm
Hi all i was drving to work today and all of a sudden i got a error on the dash saying srs fault. Now when i start the car the error is always on and I have the srs light on. I have checked the fuse under the dash and I am 100% sure no air bags have gone off the selt belt pre tentsoners are both fine I have checked them also and they look fine any help???
 

Benboy

Well-Known Member
Joined
Aug 26, 2007
Messages
2,467
Reaction score
86
Points
48
Location
Hill River, SA
Members Ride
2007 SVZ Wagon
Sounds like you need to make an appointment with your local workshop mechanic.
 

Skooby

New Member
Joined
Sep 5, 2008
Messages
184
Reaction score
1
Points
0
Members Ride
VY II SS
You will need someone who uses a Tech2 scan tool.

They can clear the code for you, and tell you what the fault it, and if the fault comes back again, you will have to have it fixed.

Tech2's are expensive, so not that many workshops have them.
 

my03equipe

New Member
Joined
Apr 8, 2010
Messages
11
Reaction score
0
Points
0
Members Ride
03 VY EQUIPE
Just had same prob in my vy equipe, had it checked and came up with 2 old codes. No apparent problem, codes were cleared and 1hr later same issue again. SRS has not been activated as far as I know nor pre tesioners. Hmmmm.

Holden dealership none too helpful either, want money first.
 

PaulSV6

CHE Tuned 156.8rwkw
Joined
Jun 10, 2008
Messages
1,384
Reaction score
9
Points
0
Location
Castle Hill
Members Ride
VZ SV6 M6, MY10 VE SV6 Sportswagon & MY03 XC SRI
^^^Doubt it. There will still be a fault somewhere in the SRS system. Take it to someone with Tech2, better be safe than sorry!
 

specter

New Member
Joined
Oct 30, 2006
Messages
17
Reaction score
1
Points
1
Location
Perth
Members Ride
VS S 6cyl auto Ute
Try cleaning the connection between the seat and body harness with a little wet&dry and electrical cleaner. You will still have to use a magic machine to reset the light though .....
 

ERDEM_CIMBOM

New Member
Joined
Dec 14, 2008
Messages
28
Reaction score
0
Points
0
Location
Melbourne
Members Ride
vy s ute series II 2003
if after you reset the codes and the srs light still comes on, check ur airbag module, i had this problem and the tech2 scan tool didnt notify me of the problem, i went trough 2 new pretensioners before i found out it was that.
 
Top