Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

strange throttle problem

simoj

New Member
Joined
Jan 20, 2011
Messages
8
Reaction score
0
Points
0
Location
adelaide
Members Ride
VTII Berlina
firstly i have a VTII berlina which has been running great ever since i got it. recently i got it serviced and ever since theres been problems. my latest issue has been with the throttle position sensor. the light keeps coming on and then the revs pick up. but then i turn the car on and off and the issues gone. this didnt worry me until i got in my car yesty and turned it on no problem but then i went to rev it ( only a little up to 1500rmp) and it choked and almost stalled. im assuming that there is something wrong with my throttle. any suggestions?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,264
Reaction score
459
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V

DLFHUB666

GIT 'EERRR DONE!!!
Joined
Jun 14, 2010
Messages
1,375
Reaction score
20
Points
38
Age
36
Location
Nhulunbuy NT
Members Ride
VX SS, PX Ford Ranger XLS Dual cab
If you can get a hold of a scan tool that does live readings you will be able to see what the TPS is doing an rule it out/in as the problem.
 

vncruzr

Member
Joined
Jan 25, 2007
Messages
167
Reaction score
3
Points
18
Location
wyndhamvale vic
Members Ride
VY LS1
Mate try change the throttle sensor not that expensive also check for split or broken rocker cover to throttle body hoses!!!! Mate my brother had the same prob.... in his calias and it was the sensor!!!!
 

simoj

New Member
Joined
Jan 20, 2011
Messages
8
Reaction score
0
Points
0
Location
adelaide
Members Ride
VTII Berlina
cheers i had a mechanic plug his computer in and it said it was the throttle position sensor going off. wat reasons could cause it to go off?
 

DLFHUB666

GIT 'EERRR DONE!!!
Joined
Jun 14, 2010
Messages
1,375
Reaction score
20
Points
38
Age
36
Location
Nhulunbuy NT
Members Ride
VX SS, PX Ford Ranger XLS Dual cab
Just buy a new 1 on an be done with it.
 

simoj

New Member
Joined
Jan 20, 2011
Messages
8
Reaction score
0
Points
0
Location
adelaide
Members Ride
VTII Berlina
i bought a new 1 and installed it seems to be running fine. cheers for the tips. i was just wondering wat could make the TPS go off?
 

smickgmh

New Member
Joined
Feb 9, 2011
Messages
6
Reaction score
0
Points
0
Location
ballarat
Members Ride
vx ss
im having problems with my vx ss throttle sensor computer i think ? the car starts then stalls as if theres no fuel ? and the computer in the kick panel is getting hot ?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,264
Reaction score
459
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
i bought a new 1 and installed it seems to be running fine. cheers for the tips. i was just wondering wat could make the TPS go off?
They just wear out with age.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,264
Reaction score
459
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
im having problems with my vx ss throttle sensor computer i think ? the car starts then stalls as if theres no fuel ? and the computer in the kick panel is getting hot ?
As suggested in the second reply to this thread, do a fault (error) code check. There is a link to how to do it.
 
Top