Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Tacho issue - 84 VK

Scatman696

Member
Joined
Feb 17, 2024
Messages
86
Reaction score
23
Points
8
Age
47
Location
Currans Hill NSW
Members Ride
Vk berlina
Hey All,

I have just had original dash cluster repaired and all was working well with an additional monster tacho in line with the dash tacho yesterday.

Today the dash tacho has stopped working.

My questions are

Can I run two tachos? (Previous owner set up)

Is it better to just run the one tacho? (My preference) original dash looks better

Is the other tacho (monster) affecting the vk dash tacho?

Thanks for any advice or help.

Cheers
 

gtrboyy

Well-Known Member
Joined
Jan 25, 2006
Messages
4,295
Reaction score
2,814
Points
113
Members Ride
vt ss & lc gtr
Personally think that as long as monster tacho is not tapped off same wires & power source of factory tacho then both should work fine....also makes it easier to remove if want to neaten interior or put it on another car.
 

Scatman696

Member
Joined
Feb 17, 2024
Messages
86
Reaction score
23
Points
8
Age
47
Location
Currans Hill NSW
Members Ride
Vk berlina
Personally think that as long as monster tacho is not tapped off same wires & power source of factory tacho then both should work fine....also makes it easier to remove if want to neaten interior or put it on another car.
Yeah I have removed the bloody tacho - got the cluster back again with rpm fixed (another $200 gone - ouch) and it seems to be fine.

Fingers crossed it stays fine. The repair guy said it’s likely the monster tacho that was piggy backed onto the original was more than likely the culprit.

Thanks for your reply.

Cheers
 
  • Like
Reactions: Lex

gtrboyy

Well-Known Member
Joined
Jan 25, 2006
Messages
4,295
Reaction score
2,814
Points
113
Members Ride
vt ss & lc gtr
Yeah when got my sle noticed digital autometer tacho was 'glitchy' so ended up rewiring it seperately.

Did take it out completely but hated holes on top of steering column so put it back in grrrr

Sle did have old style monster tacho in pillar but cant see srcew holes unless you purposely try to find them.
 
Top