Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

The creaking sound my car makes is driving me insane!!

Fu Manchu

Septic Tank Pump Operator
Joined
Mar 18, 2006
Messages
11,038
Reaction score
10,047
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, & ya mum.
You gotta replace those. I use the poly/rubber combo ones.
 

Rogue Trooper

Member
Joined
Oct 13, 2009
Messages
54
Reaction score
12
Points
8
Location
Lower Hutt, New Zealand.
Members Ride
2010 SII SV6
IIRC, there was a semi-common issue with squeaking driver's seats in VE.

A search here might provided the solution.

Had this issue myself. If it's the same problem then solution here...

 

Pauldw500

Well-Known Member
Joined
Aug 8, 2020
Messages
885
Reaction score
622
Points
93
Age
52
Location
Brisbane
Members Ride
HSV Clubsport
What weight are you towing, and how long for? You may have stretched your car. Sounds daft I know, but it does happen. This may cause a creaking panel. Just a thought.
OK just drove the car. Last time I drove it I was towing and it was creaking so bad I was cursing the car and misso said I should sell it... o_O

Anyway, just drove 5 mins to shops and not 1 creak. Maybe I HAVE stretched something.

I have knocking from front nearside but know what it is. Gonna get wheels off and either give another degrease and rinse, or may e just spray some silicon spray in there...

Love / hate relationship with my car as said before, and I sometimes think it would be nice with some leccy gadgets a nice smaller newer car would have...

Hmmmm....
 

Pauldw500

Well-Known Member
Joined
Aug 8, 2020
Messages
885
Reaction score
622
Points
93
Age
52
Location
Brisbane
Members Ride
HSV Clubsport
Sway bar joints to blame apparently. 3 mechanics have had a look/listen and all say it's the rubbers in the sway bay.

I've sprayed them both heaps with WD40 and it still creaks... :mad: :mad: :mad: :mad: :mad:

WTF....
 

mpower

Well-Known Member
Joined
Jan 22, 2007
Messages
5,006
Reaction score
1,606
Points
113
Location
Brisbane
Members Ride
V2 CV8 Monaro and VF SSV Redline
Sway bar joints to blame apparently. 3 mechanics have had a look/listen and all say it's the rubbers in the sway bay.

I've sprayed them both heaps with WD40 and it still creaks... :mad: :mad: :mad: :mad: :mad:

WTF....

WD40 is not a lubricant it is a water dispersant (it dries out), try a lubricant. Something rubber safe.
 

Martbar

Well-Known Member
Joined
Dec 31, 2021
Messages
440
Reaction score
253
Points
63
Age
65
Location
New Zealand S.I. Otago.
Members Ride
VE Commodore Calaisv L76 motor
WD40 is not a lubricant it is a water dispersant (it dries out), try a lubricant. Something rubber safe.
Yes the silicone spray l've got is a water dispersant as well. Definitely wouldn't help to lubricate squeaky bushings.
 

Pauldw500

Well-Known Member
Joined
Aug 8, 2020
Messages
885
Reaction score
622
Points
93
Age
52
Location
Brisbane
Members Ride
HSV Clubsport
So tried both WD40 and silicone spray...

I might just take the damn sway bar off the car...
 

mpower

Well-Known Member
Joined
Jan 22, 2007
Messages
5,006
Reaction score
1,606
Points
113
Location
Brisbane
Members Ride
V2 CV8 Monaro and VF SSV Redline
So tried both WD40 and silicone spray...

I might just take the damn sway bar off the car...

then you could put some kind of grease into it which may just not have been done at install.

If you wish to continue with sprays maybe a white lithium spray instead.

WD-40 also make one of those, but i dunno, that's more of a metal to metal - i guess it could work?

 
Top