Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Thermo fans don't stop after turning off ignition.Have to dissconect to stop them.

Ray o

New Member
Joined
Feb 12, 2019
Messages
4
Reaction score
0
Points
1
Age
73
Location
Maryborough qld
Members Ride
Commodore crewman vz
Can anyone suggest a reason and how to fix.
Cheers,
Ray
 

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
2,998
Reaction score
1,492
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Faulty Thermo Fan Relay ?
 

Ray o

New Member
Joined
Feb 12, 2019
Messages
4
Reaction score
0
Points
1
Age
73
Location
Maryborough qld
Members Ride
Commodore crewman vz
have you got the right relays installed? if you pull the relay out and reinsert does the fan stop or come back on?
Haven't tried that but l will.The strange thing is this only happens ONE out of six times. Relays have been replace d.
 

DeanoV6

Member
Joined
Feb 9, 2010
Messages
52
Reaction score
3
Points
8
Members Ride
VZ Executive
Disconnect Battery for 30 seconds, reconnect should be all good.
 

wildfiremaint

Active Member
Joined
Jan 3, 2006
Messages
267
Reaction score
113
Points
43
Location
Sydney
Members Ride
VR SS , 2007 Subaru LIBERTY Wagon
Possible intermittant short to
ground between relay and ECU.
May have to check the harness
for frayed insulation. :(
 
Top