Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Thermo fans running all the time

Getthebook

New Member
Joined
Mar 11, 2019
Messages
9
Reaction score
4
Points
3
Age
53
Location
Melbourne
Members Ride
Vs Commodore UTE series 2 3.8 v6
I have VS ute 3.8 v6 factory air. When I purchased it was told the a/c was working but had stopped. A/c currently does not engage but I think it’s out of gas anyway

I found the wire to the compressor ( 1 wire) was broken so proceeded to re solder on to resolve the issue

Still nothing and the fans run as soon as you turn ignition on hot or cold

Reading another forum as suggested I replaced the ECU sensor in the thermostat thinking this may sort out but still the fans run

I have tested computer with pin 5 and 6 and it comes up with 12 no errors

I have no current to the a/c compressor but was told due to no gas it would not switch on

Checked all fuses and relays

Lost where to look next. Your help would be greatly appreciated
 

BlackVXGTS

Well-Known Member
Joined
Aug 14, 2004
Messages
4,716
Reaction score
1,446
Points
113
Location
Melbourne, SE
Members Ride
GEN-F2 GTS A6, VS Clubsport 185 A4
Attached are diagnostic charts from the Holden VR/VS Service manual which may help you with your problems (or may just flood you with too much information LOL).
 

Attachments

  • VS V6 PCM AC Clutch Control Chart A-11.1.pdf
    240.4 KB · Views: 79
  • VS V6 PCM AC Clutch Control Chart A-11.2.pdf
    229.6 KB · Views: 68
  • VS V6 PCM Electric Fan Control Chart A-12.1.pdf
    246.5 KB · Views: 81
  • VS V6 PCM Electric Fan Control Chart A-12.2.pdf
    239.5 KB · Views: 83
  • VS V6 PCM Electric Fan Control Chart A-12.3.pdf
    239.5 KB · Views: 68

Getthebook

New Member
Joined
Mar 11, 2019
Messages
9
Reaction score
4
Points
3
Age
53
Location
Melbourne
Members Ride
Vs Commodore UTE series 2 3.8 v6
Thanks the flow chart I will try tomorrow but the first three steps sound like my exact problem
 

Getthebook

New Member
Joined
Mar 11, 2019
Messages
9
Reaction score
4
Points
3
Age
53
Location
Melbourne
Members Ride
Vs Commodore UTE series 2 3.8 v6
All good followed flow chart turned up a faulty or wrong BCU l

Considering my ute key has a boot open button and it’s a ute it seems to have been replaced at some time

How do I know the correct bcm or the car??
 

vs-lover

Well-Known Member
Joined
Mar 9, 2013
Messages
2,478
Reaction score
1,650
Points
113
Location
Adelaide
Members Ride
VS S2 Calais, VS S2 Exec Wagon, VS S2 Acclaim
That would signify that you have a Berlina or higher level BCM fitted, but that's highly unlikely and I'm pretty sure not possible. What you'll find is that many 2 button keys are now replaced with 3 button key blanks and programmed to suit. this is becoming quite the norm for the key retailers to just keep stock of one type of blank. My sons VS Exec had a 3 button key added to it by the previous owner along with the original 2 button key that came with the car when we bought it for a whole $300. This car still has all it's original gear fitted along with its original BCM.
 

Getthebook

New Member
Joined
Mar 11, 2019
Messages
9
Reaction score
4
Points
3
Age
53
Location
Melbourne
Members Ride
Vs Commodore UTE series 2 3.8 v6
Many thanks you blokes are on the ball. I called Holden and got the part number based on the original vin number that directed me to a different BCM. Local wrecker had one so bought it for 50 bucks. Will advise outcome but the low fan control on your suggested BCM is where my problems are. Fingers crossed and will update when it arrives
 

vs-lover

Well-Known Member
Joined
Mar 9, 2013
Messages
2,478
Reaction score
1,650
Points
113
Location
Adelaide
Members Ride
VS S2 Calais, VS S2 Exec Wagon, VS S2 Acclaim
I hope you got a key head with the BCM, if not it's a useless boat anchor and not worth fitting.
 

Getthebook

New Member
Joined
Mar 11, 2019
Messages
9
Reaction score
4
Points
3
Age
53
Location
Melbourne
Members Ride
Vs Commodore UTE series 2 3.8 v6
Yes mate got the key fob. Am told as it’s a series 2 I don’t need to touch the ecu or program it like with the VT ‘s

Jury is out but hopes are high

Always return for a refund ( love Paypal) otherwise will post if anybody needs a boat anchor ⛴⚓⚓
 

EYY

Well-Known Member
Joined
Mar 6, 2011
Messages
5,444
Reaction score
1,512
Points
113
Location
Vic
Members Ride
VS Statesman
Yes mate got the key fob. Am told as it’s a series 2 I don’t need to touch the ecu or program it like with the VT ‘s

Jury is out but hopes are high

Always return for a refund ( love Paypal) otherwise will post if anybody needs a boat anchor ⛴⚓⚓
Yep that’s right, don’t need to link anything. Plug in, change your keyhead and go.

Have you tried replacing the fan relays too? Contacts can sometimes become stuck in the closed position.
 
Top