Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Top of selector/heat/fan light blown

Avi8or

Luxo-barging
Joined
Jan 12, 2006
Messages
209
Reaction score
0
Points
16
Location
Adelaide
Members Ride
WM Caprice 6L
The top section of my zone selector/fan control/heat level thing (no idea what its called) no longer lights up so im guessing the globe has gone. Just wondering if anyone knows what sort of globe it is (so i can get it before pulling the car apart) and how hard it is to replace?
 

holden007

VRII
Joined
Dec 18, 2003
Messages
1,104
Reaction score
1
Points
0
Members Ride
Subaru Liberty
I know how the bulb looks, its those tiny things, dont know the exact detail...someone help:)
 

Torquen

Boost FTW
Joined
Mar 26, 2006
Messages
568
Reaction score
1
Points
0
Age
31
Location
Perth, WA
Members Ride
450+ HP FORD XR6T
i have the same probslem. im guessing blown bulb 2.
 

DeiCide

DeiCide
Joined
Jan 1, 2006
Messages
237
Reaction score
1
Points
18
Location
Adelaide
Members Ride
VT S2 L67
*Same problem... but all my globes have gone!
Been meaning to fix it when I tie down the stereo, u need to take a bits of the panels off, glove box, centre console flap, etc. Annoyning job imo. Never get everything to sit just how it was, (creeks, and plastic rubbing noises whenever going over bumps)
 

Patrio7

3Y3 K4N 5P33K 1337.
Joined
Jul 25, 2005
Messages
1,269
Reaction score
25
Points
0
Age
35
Location
Perth, Como
Members Ride
'96 S1 VS Exec
yeah my selection and fan speed lights are gone too lmao, cbf replaceing atm.
need to do my fan speed resistor too....
 

haloeight

New Member
Joined
Apr 12, 2004
Messages
390
Reaction score
4
Points
0
Age
42
Location
Adelaide
Members Ride
VS Stato SII L67 S/C V6
check all ure fuses first

i spent a frustrating day replacing every single "grain of wheat bulb" all thru the console, fag lighter the whole lot, only to have none work when i started up...not happy

changed a 40c fuse and off she went again!
 

Slow VR

Another White Crummodore
Joined
Apr 14, 2006
Messages
357
Reaction score
3
Points
0
Location
Cairns, Nth Qld
Members Ride
VR Series II
The bulbs are cheaply available from Repco, they have a blade fitting on the end where they slip into the socket. It can be hard to remove the old 1s from there socket. U may smash a bulb getting it out.

Simply pull the plastic up from around the shifter, remove the 3 screws from the bottom part of the centre console under the stereo. Pull that piece out, then remove the single screw retaining the Fan/Temp cluster. Dial it up to hot and it will come out a little way.

Around the edge of it u will c 6 clips where the black facia clips onto the white cluster section, remove the 2 dials and button for fan speed, poke a flat blade into those clips gently and it will all fall off. Revealing the 2 bulbs.

When installing the new bulbs the entire socket may push all the way in. This will mean removal of the White cluster, its easy as. Undo 2 plugs, undo the vac lines, undo the temp control rod next to ur left foot under the dash.

Fan speed resistor assy is under the plastic cowl at the bottom of ur windscreen. U need to pull ur wipers off for that 1!
 
Top