Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

TPS issue driving me mad...

madfrankie

New Member
Joined
Feb 22, 2010
Messages
3
Reaction score
0
Points
0
Members Ride
VT Olympic
Hi y'all,

I've got a drama with my VT Olympic that is driving me completely mad.
The gear changes are all off pretty much all the time - sometimes it will stick in a gear when it should be changing or it will change down when it shouldn't.
It's also randomly throwing a TPS error and lighting up the powertrain light, at which point it makes a nasty 'clonk' every time it changes gear and has to be stopped and turned off to reset. After this it will behave for a while again.

I've had it into the mechanics and auto elec a stack of times now and they still haven't managed to fix it.
So far it's had:

1. new TPS (holden genuine)
2. All new wiring form TPS to computer
3. Computer tested ok.

Wondering if anyone else out there has had the same issues and discovered the cause?

Any help at all would really be appreciated!

Cheers!
 

chargedvx6

Active Member
Joined
Dec 9, 2006
Messages
1,866
Reaction score
15
Points
38
Members Ride
VY SII HBD Calais L67
The coolant temp sender and TPS share the same earth. Might be another avenue to follow. You haven't got a ported throttle body by any chance do you?
 

madfrankie

New Member
Joined
Feb 22, 2010
Messages
3
Reaction score
0
Points
0
Members Ride
VT Olympic
Thanks for the reply, the autoelec checked the earth circuit and replaced all that wiring too just to be sure.
Dunno about the the ported throttle body, I'm a bit of a space cadet really. What would it mean if I do?
 

jetjnr

New Member
Joined
Nov 5, 2009
Messages
22
Reaction score
0
Points
0
Members Ride
VT wagon
Have you reset the ECU after you replaced the TPS?
And what did you use to test the ECU?
 

madfrankie

New Member
Joined
Feb 22, 2010
Messages
3
Reaction score
0
Points
0
Members Ride
VT Olympic
I didn't do the replacement, so not sure if the mechanics did reset it, will check with them.
Cheers!
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,989
Reaction score
431
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
some of the holden throttlebodys require a plastic adaptor on the end of the butterfly shaft where the tps goes over it if its fallen off the tps reads funny and spits codes etc
 
Top