Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Transmission downshift problem and thump

Discussion in 'VT - VX Holden Commodore (1997 - 2002)' started by Juice3, Jan 10, 2020.

  1. Juice3

    Juice3 Active Member

    Messages:
    170
    Likes Received:
    29
    Trophy Points:
    28
    Joined:
    Feb 8, 2015
    Location:
    Australia
    Members Ride:
    VX
    My holden vx series 2 has an intermittent problem with downshifting sometimes when I speed off from a stop it speeds up gradually like its starting off in 3rd gear other times it speeds off like a rocket same thing when going up hills. A new thing it did today when I tried to speed off from a stop is that it didnt speed off at all i went to speed through the roundabout and got two harsh thumps. This transmission has been serviced regularly and recently replaced tps sensor,shift solenoids but didn't make any difference.
     
  2. ant797

    ant797 Active Member

    Messages:
    472
    Likes Received:
    56
    Trophy Points:
    28
    Joined:
    Nov 29, 2012
    Location:
    bunbury
    Members Ride:
    vy s
    might have something to do with torque clutch lock up solenoid
     
    Juice3 likes this.
  3. immortality

    immortality Home of the smoky breakfast Bacon! Staff Member

    Messages:
    14,680
    Likes Received:
    2,625
    Trophy Points:
    113
    Joined:
    Apr 15, 2006
    Location:
    Sth Auck, NZ
    Members Ride:
    HSV VS Senator, VX s2 Calais S/C
    Maybe the trans is just worn out?

    Been a lot of new but faulty tps problems of late too.
     
    Juice3 and losh1971 like this.
  4. ant797

    ant797 Active Member

    Messages:
    472
    Likes Received:
    56
    Trophy Points:
    28
    Joined:
    Nov 29, 2012
    Location:
    bunbury
    Members Ride:
    vy s
    im replacing my new tps see if it solves my prob i got it for 17 bucks a year ago for another vy i got when the online auto stores wee selling cheap ebay stuff they are selling name brands now
     
    Juice3 likes this.
  5. Trevor loves holden.

    Trevor loves holden. Well-Known Member

    Messages:
    2,428
    Likes Received:
    430
    Trophy Points:
    83
    Joined:
    Jun 6, 2019
    Location:
    Victoria
    Members Ride:
    vs commodore
    Might be the valve body, you can get a upgrade kit with a better spring, best to have a transmission place have a look.
     
    Juice3 likes this.
  6. Utel67

    Utel67 Active Member

    Messages:
    236
    Likes Received:
    91
    Trophy Points:
    28
    Joined:
    Jul 15, 2019
    Location:
    Tasmania
    Members Ride:
    Vs s3 ute
    Sounds like a electrical problem, check wiring harness to transmission or faulty PCM.
     
    Juice3 likes this.
  7. BlackVXGTS

    BlackVXGTS Well-Known Member

    Messages:
    3,550
    Likes Received:
    544
    Trophy Points:
    113
    Joined:
    Aug 14, 2004
    Location:
    Melbourne, SE
    Members Ride:
    GEN-F2 GTS A6, VS Clubsport 185 A4
    Has the check engine light come on at all? Have you displayed your error codes? Sounds like you trans might be going into "limp home mode".
     
    Juice3 likes this.
  8. Juice3

    Juice3 Active Member

    Messages:
    170
    Likes Received:
    29
    Trophy Points:
    28
    Joined:
    Feb 8, 2015
    Location:
    Australia
    Members Ride:
    VX
    Check engine light not on and checked for codes with tunerpro and got none the only faults I got is quad drive 1 and 2 but this is normal from what i've read.
     
  9. Juice3

    Juice3 Active Member

    Messages:
    170
    Likes Received:
    29
    Trophy Points:
    28
    Joined:
    Feb 8, 2015
    Location:
    Australia
    Members Ride:
    VX
    I replaced the tps twice this time it's got a delphi sensor other one I bought from supercheap online. If trans was worn out tho why would it shift beautifully one day and then the next day not downshift when its supposed to? also this trans has only 200,000km on it and I have serviced it regularly since I got the car when it had only 47,000km on it and dont abuse it either.
     
  10. immortality

    immortality Home of the smoky breakfast Bacon! Staff Member

    Messages:
    14,680
    Likes Received:
    2,625
    Trophy Points:
    113
    Joined:
    Apr 15, 2006
    Location:
    Sth Auck, NZ
    Members Ride:
    HSV VS Senator, VX s2 Calais S/C
    This is a question I've pondered often. I'm suspecting it could be a seal issue as there are a number of rubber seals in the various parts and seals go hard with age and effected by heat which might effect how the transmission performs day to day.
     

Share This Page