Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Transmission downshift problem and thump

Juice3

Active Member
Joined
Feb 8, 2015
Messages
228
Reaction score
42
Points
28
Location
Australia
Members Ride
VX
My holden vx series 2 has an intermittent problem with downshifting sometimes when I speed off from a stop it speeds up gradually like its starting off in 3rd gear other times it speeds off like a rocket same thing when going up hills. A new thing it did today when I tried to speed off from a stop is that it didnt speed off at all i went to speed through the roundabout and got two harsh thumps. This transmission has been serviced regularly and recently replaced tps sensor,shift solenoids but didn't make any difference.
 

ant797

Active Member
Joined
Nov 29, 2012
Messages
655
Reaction score
100
Points
43
Location
bunbury
Members Ride
vy s
might have something to do with torque clutch lock up solenoid
 

immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
17,898
Reaction score
6,986
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX s2 Calais S/C
Maybe the trans is just worn out?

Been a lot of new but faulty tps problems of late too.
 

ant797

Active Member
Joined
Nov 29, 2012
Messages
655
Reaction score
100
Points
43
Location
bunbury
Members Ride
vy s
Maybe the trans is just worn out?

Been a lot of new but faulty tps problems of late too.
im replacing my new tps see if it solves my prob i got it for 17 bucks a year ago for another vy i got when the online auto stores wee selling cheap ebay stuff they are selling name brands now
 

Trevor loves holden.

Well-Known Member
Joined
Jun 6, 2019
Messages
3,505
Reaction score
743
Points
113
Location
Victoria
Members Ride
vs commodore
Might be the valve body, you can get a upgrade kit with a better spring, best to have a transmission place have a look.
 

Utel67

Active Member
Joined
Jul 15, 2019
Messages
341
Reaction score
144
Points
43
Location
Tasmania
Members Ride
Vs s3 ute
Sounds like a electrical problem, check wiring harness to transmission or faulty PCM.
 

BlackVXGTS

Well-Known Member
Joined
Aug 14, 2004
Messages
4,403
Reaction score
1,126
Points
113
Location
Melbourne, SE
Members Ride
GEN-F2 GTS A6, VS Clubsport 185 A4
Has the check engine light come on at all? Have you displayed your error codes? Sounds like you trans might be going into "limp home mode".
 

Juice3

Active Member
Joined
Feb 8, 2015
Messages
228
Reaction score
42
Points
28
Location
Australia
Members Ride
VX
Has the check engine light come on at all? Have you displayed your error codes? Sounds like you trans might be going into "limp home mode".
Check engine light not on and checked for codes with tunerpro and got none the only faults I got is quad drive 1 and 2 but this is normal from what i've read.
 

Juice3

Active Member
Joined
Feb 8, 2015
Messages
228
Reaction score
42
Points
28
Location
Australia
Members Ride
VX
Maybe the trans is just worn out?

Been a lot of new but faulty tps problems of late too.
I replaced the tps twice this time it's got a delphi sensor other one I bought from supercheap online. If trans was worn out tho why would it shift beautifully one day and then the next day not downshift when its supposed to? also this trans has only 200,000km on it and I have serviced it regularly since I got the car when it had only 47,000km on it and dont abuse it either.
 

immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
17,898
Reaction score
6,986
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX s2 Calais S/C
This is a question I've pondered often. I'm suspecting it could be a seal issue as there are a number of rubber seals in the various parts and seals go hard with age and effected by heat which might effect how the transmission performs day to day.
 
Top