Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

[Alloytec] Turbo'd VE V6 Oil drainage issue. Turbo experts please help!

Discussion in 'V6 Development And Modification' started by mrscholz, May 31, 2013.

  1. mrscholz

    mrscholz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Oct 18, 2010
    Location:
    Dubbo, Australia
    Members Ride:
    VE Berlina
    Just finished turbo-ing and tuning a '07 VE V6 Omega. The Turbo is a water cooled GT35R Journal bearing type. I have one problem that is doing my head in... the oil drain from the turbo. Because it is a low-mount, I have got a VDO scavenge pump running off the drain line back to the rocker cover. The pump runs off a turbo timer to continue after the ignition is switched off, I have a one way check valve on the oil inlet side coming from the pressure sender under the oil filter, and a 1mm restrictor. The drain line and the VDO pump both sit below the center of the turbo, and are connected by a 90 degree elbow from the drain port on the turbo. THE PROBLEM... I'm still getting oil being pushed past the bearings. Do I need a vented sump? A better pump? Should I need the restrictor? Do I need a one way valve leaving the turbo as well? Any help would be awesome. Thanks in advance.
     
  2. delcowizzid

    delcowizzid on holiday

    Messages:
    6,877
    Likes Received:
    346
    Trophy Points:
    83
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    does it run a real small air filter if so it can make the compressor housing fill with oil from the vacuam created happens a lot
     
  3. mrscholz

    mrscholz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Oct 18, 2010
    Location:
    Dubbo, Australia
    Members Ride:
    VE Berlina
    I have got a drift pod filter on it.... Its not the biggest of pods might try and find one with a bigger flow?
     
  4. v6 morrie minor

    v6 morrie minor New Member

    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 21, 2013
    Location:
    new zealand
    Members Ride:
    vr v6
    Pod filter should be fine and yes you need a restrictor, i had trouble with mine until i put a 1.3mm restrictor and mine is a front high mount with drain straight to sump. The dino tune guys told me that it comes out of the turbo like foam so i dont know how your pump will go sucking foam until it reforms itself into oil again. Maybe you should do a search for low mount skyline and see how the ricers do it.
     
  5. delcowizzid

    delcowizzid on holiday

    Messages:
    6,877
    Likes Received:
    346
    Trophy Points:
    83
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    journal bearing turbo wont last long with a restrictor they require full flow
     
  6. v6 morrie minor

    v6 morrie minor New Member

    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 21, 2013
    Location:
    new zealand
    Members Ride:
    vr v6
    Hey mate sorry for the bad info on the restrictor, I have been talking to delcowizard and he knows his stuff. i hadn't blocked the pcv valve so have now opened my oil out to see how it goes.Looks like his goes real good from the vids he posted. GOOOOD skids
     
  7. villn808

    villn808 Active Member

    Messages:
    398
    Likes Received:
    140
    Trophy Points:
    43
    Joined:
    Apr 13, 2013
    Location:
    Melbourne, SE Suburbs
    Members Ride:
    MY15 SSV Sedan
    Do you have any more info/pics on this build mate?
     
  8. rubaduckee

    rubaduckee New Member

    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Feb 11, 2009
    Members Ride:
    vp
    Due to space I only run a fat but narrow air filter and having some issues, mine is high mount drain straight to the sump
     
  9. delcowizzid

    delcowizzid on holiday

    Messages:
    6,877
    Likes Received:
    346
    Trophy Points:
    83
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    short ones like this cause issues very easy
    [​IMG]
    by rights you really need a 12" long k&n if making resonable power.we are starting to get slight film of oil at 14psi with a normal standard size pod filter its just not got enough surface area its even sucked the material out of the mesh its struggling for air LOL
     
  10. rubaduckee

    rubaduckee New Member

    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Feb 11, 2009
    Members Ride:
    vp
    That's what mine looks like lol
    So not only affecting my power output but also causing it to smoke, just gotta see if I can do something else, maybe run a flexible hose to front of bar and put a bigger filter on it?
     

Share This Page