Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

turning over slow and not charging

Status
Not open for further replies.

wayne0

New Member
Joined
Aug 29, 2010
Messages
18
Reaction score
1
Points
3
Location
Clive
Members Ride
vt 5.7 series III 6sp
Right then
I bought a VY 3.8 cheap for my son, when bought was told alternators not charging as the battery leads had been connected to the wrong battery terminals. Car starts and drives but isn't charging and turns over very slowly when starting, even with a good battery, the alternator would start to smoke after a short time.
Replaced alternator with one from a wreckers.
Still turns over very slowly and is not charging but no smoke from the alternator now.
Have checked fuses and all are good, visually inspected wiring and cant find any burnt, damaged on loose wires. Everything else appears to be working fine expect the radio.
Could the alternator from the wreckers be no good, how can I check this on the bench with a multi meter and what else could be causing these problems.
Much appropriate your help, thanks
 

immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
17,922
Reaction score
7,039
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX s2 Calais S/C
Only one thread required and a little patience!
 
Status
Not open for further replies.
Top