Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Unburnt fuel

gimmemud

Member
Joined
Jan 11, 2009
Messages
32
Reaction score
0
Points
6
Location
Auckland, NZ and Cairns, OZ
Members Ride
VP v6 in Hilux and VY SV8
Hey all, I found a couple threads on this but still didn't really answer my questions.
I've got a vp 3.8 in my Toyota surf, and it's spitting out a heap of unburnt fuel. If I tow a trailer it gets absolutely coated. The spark plugs get fouled up pretty quick, and after the engines warm and been driving on the highway it coughs and splatters, then stalls when going to lower revs. I'm using the surf's in tank fuel pump which could be putting too much pressure in the fuel rail, but that shouldn't matter with the pressure relief back to the tank? I've got a "stage 3 memcal" ECU, but I have tried a standard one and the same thing happens. Anyone got ideas to fix? Was thinking a fuel regulator before the fuel rail? Cheers in advance
 

MikeC

Active Member
Joined
Jan 10, 2010
Messages
697
Reaction score
164
Points
43
Members Ride
VQ Statesman
Temperature sensor feeding the ECU connected and working? If not the ECU will sense the engine is cold and richen the fuel supply injected up- as in applying the old choke.
 

gimmemud

Member
Joined
Jan 11, 2009
Messages
32
Reaction score
0
Points
6
Location
Auckland, NZ and Cairns, OZ
Members Ride
VP v6 in Hilux and VY SV8
Temperature sensor feeding the ECU connected and working? If not the ECU will sense the engine is cold and richen the fuel supply injected up- as in applying the old choke.
Yeah there's one for the gauge an one for the ECU. Could be faulty though I guess, hadn't thought of that
 

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,937
Reaction score
1,205
Points
113
Members Ride
Zenki S14
I've got a "stage 3 memcal" ECU, but I have tried a standard one and the same thing happens.
Would advise ditching that anyway, sounds like an ebay special.
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,289
Reaction score
6,535
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
I've got a "stage 3 memcal" ECU, but I have tried a standard one and the same thing happens.
Hmmm yeah, stage 3 memcal, interesting? I didn't realise memcals were like cams with different stages. Does sound like an eBay special?
 

gimmemud

Member
Joined
Jan 11, 2009
Messages
32
Reaction score
0
Points
6
Location
Auckland, NZ and Cairns, OZ
Members Ride
VP v6 in Hilux and VY SV8
Yeah the original computer took a swim, this one was only a little extra so thought I'd give it a go. The only difference I could tell was that it removed the 5500rpm rev limit
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,289
Reaction score
6,535
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
Probably best to get a stock ECU and see if that helps.
 

Trevor loves holden.

Well-Known Member
Joined
Jun 6, 2019
Messages
3,505
Reaction score
743
Points
113
Location
Victoria
Members Ride
vs commodore
Sounds like a injector are staying open, make sure your injectors are pulsating also check the spark to the plugs.
 

gtrboyy

Well-Known Member
Joined
Jan 25, 2006
Messages
3,274
Reaction score
1,624
Points
113
Members Ride
vt ss & lc gtr
Does CEL light come on?

Checked for fault codes?
See if o2 sensor or cts code pops up.

If nothing comes up then start checking basics like fuel filter,f/pump,leads/plugs/vacuum leaks etc

Most of those ebay memcals are dog poo....the factory memcals were a little better but not by much.Memcal done by someone who knows what they're doing it will run much nicer & usually way more economic.

If in NZ hit up delcowizrd for a memcal or one of the peeps on delcohacking.
 
Top