Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vb heater/aircon fan wireing problems!

Discussion in 'VB - VK Holden Commodore (1978 - 1985)' started by superguy2211, Apr 14, 2009.

  1. superguy2211

    superguy2211 New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 14, 2009
    Members Ride:
    Vb SL/E
    hey guys

    just wonering if anyone out there has a clue whats going with my heater fan circut, no fuse in the air con slot but fuse in the fan slot the thing doesnt work put a fuse in the a/c slot and it runs when its turned off, the switch doesnt do a thing im actully missing the compresser and the front fan and a/c radiator so does that have something to do with it?
     
  2. Gse

    Gse Member

    Messages:
    143
    Likes Received:
    5
    Trophy Points:
    18
    Joined:
    Jan 14, 2006
    Members Ride:
    Opel Monza
    G,day
    I am not even from Australia but from Europe (Holland and found this site by surfing on the inet).
    I have a car here in Europe that is basicly the same as the VB Commodore (opel Monza) and the aircon system is the same as from the VB,for as far i found out.

    One of your A/C relais is ****ed,its a common problem here wenn the engines is put off and the fan motor keeps blowing a bit,its normal wenn the aircon is put on or the engine is running.
    But wenn the switch is in the 0 position it not possible for the fan to run if everything is normal.
    Here is a pic of the A/C system:

    opel, senator, monza, omega

    Relais K6 and K7 make the problem.
    The are under the bonnet in the middle of the engine bay,very easy to change by the European Monza/Senators.
     

Share This Page