Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VB Sl/E charging issues.

mikeydee

New Member
Joined
Apr 28, 2013
Messages
4
Reaction score
0
Points
1
Location
Hobart Tasmania
Members Ride
VB SL/E 310
Hi
I have recently bought a 11/78 VB SL/E 4.2 with e/windows and locking.
Car is 100% original , 125K with the original Uniroyal in the boot. Nor real rust apart from sitting under a tarp for 15 years. It is in Atlantis blue with Light
blue velour. The only thing I will do at this point is re paint it as the colour has gone off. Doo need a spare wheel well --- are they available ??? Rare spares dont have them.

My problem is that when I start it I get a very high charge rate , 17 volts+ indicated on the guage --- though I don't really trust it. , and then the charge drops
and the load on the altenator drops as well ( audible). If I try the windows at high charge they work OK at low charge very slowly. Similarly the fuel gauge reads differently.

Is there a problem with the regulators internally in the altenator or could it be a relay problem. I have heard clicking , LHS firewall but can't locate it.

Any ideas???

I grew up with these cars ---- my Dad was a director of Sydney Atkinsons in Perth. I remember their launch and indeed the smell of a new one. Dad's company car was a white SL/E with dark red interior.
Going to school in that car --- I was the coolest kid in class. He also had a shadow tone VC Beige and Bronze. Memories

Thanks
 

Tree cutter

Tree cutter
Joined
Apr 15, 2006
Messages
1,020
Reaction score
8
Points
38
Location
Mt Gambier SA
Members Ride
VX Calais SuperchargedV6
Check the battery voltage with a multimeter to make sure the guage is accurate. If it is overcharging it could be a faulty regulator or a bad connection on one of your earth or power wires. If the sense wire from the alternator is getting a bad connection it will not read correct battery voltage and therefor overcharge it.
 

mikeydee

New Member
Joined
Apr 28, 2013
Messages
4
Reaction score
0
Points
1
Location
Hobart Tasmania
Members Ride
VB SL/E 310
Hi There --- voltage --- plenty of that !! 22 volts at the battery , 17 on off vharge . So I think my regulator is cactus .

Bosch 55 amp type with an external regulator --- any ideas on sourcing a replacement regulator -- ebay ??

Cheers
Mike
 

drewVHSS

Donating Member
Joined
Apr 1, 2010
Messages
713
Reaction score
6
Points
18
Location
Gosford Central Coast
Website
stores.ebay.com.au
Members Ride
'83 VH SS, '79 Green VB SL '92 S2 VQ Caprice
any repco or bursons will be able to supply a new reg for a bosch alternator
very quick and easy to replace too. Just remember to disconnect the batter whilst replacing the reg.
 

connors

Member
Joined
Feb 21, 2013
Messages
49
Reaction score
6
Points
8
Location
Tamborine
Members Ride
HDT Commodore VK SS Group 3
Hey Mate,

What the guys said above or if in doubt take it to a "Battery World" or a battery shop where they will check the charge and battery condition, for free. Also nothing to do with charging but it wont hurt to spray your windows rubbers/runners with a little silicon spray. After sitting for so long they might be a little dry and it helps speed and smooth window operation. (Obviously if you were having voltage problems they would be slow but this just helps.)

Cheers
 
Top