Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Ve 2 ss vcm cai otr maf help

ronnny

New Member
Joined
Feb 13, 2013
Messages
19
Reaction score
0
Points
0
Location
Melbourne
Members Ride
VE Series 2 SS Ute
Hey all

Jusy got my vcm cai delivered, maf version, and the instructions on the vcm website are a little different from what i got in my package. Im having trouble finding where the brackets to push the radiator forward go.

The pictures with the install have two brackets the same whereas mine has one that looks like a c spanner.

So if anyone could help or direct me to a link that would be great.

Its a 2012 Dec build

Cheers
 

vongy10

Active Member
Joined
Feb 9, 2011
Messages
1,194
Reaction score
7
Points
38
Location
Gunnedah
Members Ride
CV8 Monaro V2
You probably bought the wrong model. Did you make sure it's for the MY12 cars?
 

Ricky

New Member
Joined
Nov 30, 2012
Messages
13
Reaction score
0
Points
0
Age
35
Location
Brisbane
Members Ride
12.5 VE SS Z Series Ute
The c spanner looking one goes on the right and pushes on the filler on the radiator and the one just clips over the top on the left. you will see the bolt holes for these on the front bar.

Can someone post him a pic please?
 

Ricky

New Member
Joined
Nov 30, 2012
Messages
13
Reaction score
0
Points
0
Age
35
Location
Brisbane
Members Ride
12.5 VE SS Z Series Ute
BTW mine is a MY12.5 and has the same brackets.
 

ronnny

New Member
Joined
Feb 13, 2013
Messages
19
Reaction score
0
Points
0
Location
Melbourne
Members Ride
VE Series 2 SS Ute
Cheers, worked it out. just the pictures on the printout on the instructions werent too clear.

Another question,

Engine light is coming on now, however the bloke at JHP said that this can happen and not to stress.
Is there any easy way to clear this?

Also, car is idling at 1500 revs now if in neutral rolling. Im guessing this is all to do with the increased airflow.

Im going to get headers and cats and a tune in a few weeks when i have the cash but if there is an easy fix in the meantime that would make life less annoying.

Thanks
 

Ricky

New Member
Joined
Nov 30, 2012
Messages
13
Reaction score
0
Points
0
Age
35
Location
Brisbane
Members Ride
12.5 VE SS Z Series Ute
Yeah mine through an engine light as well.

Drove it around like that for 4 weeks with no dramas.

Just fitted extractors and cats last night and getting it tuned next week.
 
Top