Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VE 2012 Series II Fuel Tank Removal & Pump, Fuel Control Unit & Reversing Sensor Control Unit

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
3,100
Reaction score
1,602
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Dear Members, I went shopping this afternoon and when I went to head home the car wouldn’t start, it cranked over, but it was like no fuel, where the tank is 3/4 full.
I got a family member to bring the diagnostic unit to me and it’s telling me the errors as below,
The Fault Code was on the
ECM - P069E-00
Fuel Control Module - P023F-00
My question is,
are they a common item to fail ?,
And where are they located in a Sportwagon ?,
And where is the fuse for it, as it’s not listed in the fuse box’s

Thank you in advance.
 
Last edited:

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
3,100
Reaction score
1,602
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Dear members, I did my own investigations today and located the Fuel Control Module in the Sportwagon.
It is located under the Battery Holder,
Yes, on the underside on the base of the Battery Holder/Tray.

First image - Battery, and Battery Tray removed.
Second Image - Battery Tray turned upside down. [well hidden]
Third Image - Reversing sensor unit. [removed]

Just to the Right of the Battery, is the Reversing Sensor Unit, looks similar shape to the Fuel Control Module.
 

Attachments

Last edited:

HarryHoudini

Active Member
Joined
Jan 7, 2013
Messages
491
Reaction score
90
Points
28
Location
Australia
Members Ride
1991 VN Wagon..2012 VE Sportwagon.
That's interesting,we had the battery holder out of my Neighbours VE Wagon to refit the breather i didn't notice it.Pics. will be handy when you get the time.TIA
 

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
3,100
Reaction score
1,602
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
That's interesting,we had the battery holder out of my Neighbours VE Wagon to refit the breather i didn't notice it.Pics. will be handy when you get the time.TIA
Ah yes, the damn battery breather pipe, if you accidently pull the breather pipe out, or when placing the battery back in,
you "can-not" get your hand down the side of the battery tray to push it through the rubber grommet again,
so you have to remove the 3 bolts again, remove the tray, or push it aside/foward and push pipe it through the grommet again, and re-fit the tray, and bolt it back in again.
Most importantly [the upside of pulling the battery out], while you have the battery out, check the water level on ALL cells, being the dealer says they "Check All Fluids, and top as required" knowing very well they don't, as the top hold down bracket partially covers the 2 centre cell lids,
In saying that, I did have some remnants of dry acid on 2 of the cells, and it was never wiped off in the last 3 services, which indicates, the Battery NEVER gets checked, if you were any professional "Holden Technician" [aka mechanic] you would wipe it clean.
Brighton Holden needs to lift their game. I did get a follow up phone call from the Service Department after sales, and mentioned the same, and the lady did say, that it should of been done as part of the service, and she said she would make note of it and let the service manager know, and he will give me a call to discuss it, I guess they must of lost my number, that was now over 50,000 km/s ago,
so I have since done my 135,000 k/m service [5,000 km/s ago] saving me $320 of special Holden fluids.
 
Last edited:

VS_Pete

Donating Member
Joined
Dec 23, 2007
Messages
4,871
Reaction score
18,710
Points
113
Location
Brisbane
Members Ride
VE II SV6 MY12 SPORTWAGON
Thanks for the pics mate.
You could install a longer breather pipe?
 

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
3,100
Reaction score
1,602
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Thanks for the pics mate.
You could install a longer breather pipe?
Yes, I did think of that :) , as I didn't have any clear hose on hand.
But I plan to get a metre from Supercheap next time I am there and do exactly that.
I did think of a way to NOT remove the battery to get the hose back in the grommet.

Get a old coat hanger [or similar], straighten it out, side the tube over it, poke the coat hanger wire through the grommet, then side the hose down the wire, then pull the wire out, and connect the breather to the battery. ;)
Then I can keep the old coat hanger for other useful tricks :D
 
Last edited:

VS_Pete

Donating Member
Joined
Dec 23, 2007
Messages
4,871
Reaction score
18,710
Points
113
Location
Brisbane
Members Ride
VE II SV6 MY12 SPORTWAGON

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
3,100
Reaction score
1,602
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
11/1/2019
Dear Members, I said how I was looking for Fuel Control Module, and found it, as above,
However, the problem with the car cranking and not starting was causing error P023F,
Well after reading a few posts, and seeing where the fuel pump is located, I come to the assumption that the fuel pump was faulty, after a few attempts to get it going, what I did, was remove the back seat and hit the floor pan in the vicinity of the fuel pump
[like you had to do on the VN's in the early V series commodores],
and tried to start it, and it fired up ok.
So I ordered a new Fuel Pump, and decided to replace it myself,
What a job !, as they say, Don't try this at Home
[As I did on the floor of the garage, don't get me wrong, I have all the tools to do it, but not a hoist]
FIRST THING TO DO, IS DICONNECT THE BATTERY.
I was unable to siphon the fuel out, and it has 2 parts of the tank, part of it is on the drivers side and passengers side
as the tail shaft through the under side of the centre of it.
But I did work out the cables that supplied the Fuel pump, and made a LONG lead up with a inline switch, connected a hose to the Fuel Supply line, that went back to a jerry can, and that was the only way I was able to remove the fuel,
however, it only removed the fuel on the drivers side of the tank, so the passengers still had fuel in it. But wasn't that heavy
It started out Removing the -
Rear mufflers
Plastic under body protectors,
Exhaust [from cats back to the mufflers]
Heat shield [first one]
Tail shaft
Heat shield [second one on the tank]
Disconnect the hand brake cables [fold them back onto the K frame out of the way]
Support the K frame with a trolley jack, then Loosen the rear K frame bolts [about half way as they have very long bolts - DO NOT REMOVE THEM],
Remove the front K frame bolts and let the K frame hang
Disconnect the fuel supply to the engine
Disconnect the breather pipe.
Disconnect the charcoal canister breather [this one is right on top of the tank at the back], very hard to see, "but a must do"
Undo the Tank straps and let it hang
Disconnect the filler pipe
Disconnect the filler pipe breather
Lower the Jack
Then finally removed the tank.

Removed the fuel tank loom
I blew the dust off it around the fuel pump,
Washed the tank down with a Karcher [made sure I didn't get any water in the inlet/outlets] blew the water off around the top of it where the fuel pump unit goes.
Then replaced the fuel pump unit.
I then washed down the every other item that was removed, so it wont be such a dirty job putting all back together.

But before I refitted the loom plug, I checked for any foreign objects,
and found that PIN 2 was burnt [as per image], Fuel Tank [loom] Part 92250930 [it has 5 plugs on it]
I rang around a couple of wreckers I deal with, and when I asked the first one if he had a fuel tank loom for a VE,
He then asked without hesitation, "has the plug melted", then told me that its a common problem.
We both agreed, its a bit of a time bomb, "Melting Pins on the plug next to the volatile Fuel"
Because of the work involved to drop the tank and replace the loom, I bet there wasn't a recall.
However, very dangerous.
I did read that the Fuel Pump can draw up to 10 amps,
where GM have compensated for that, by using a larger conductor [cables] Grey + [positive] and Pink - [Negative]
I am not going to get into the exact depths of how to drop the tank, there is a Youtube clip about it, [link below]

12/1/2019
I have rung around a couple of Dealers and the part has to be ordered,
where the First Dealer said a couple of days,
I said to him that the plug had melted, He said that its pretty common fault.
So Holden is aware of this also, and do nothing about it.
I bet Holdens are not the only vehicles with a deadly faults like this.
Know wonder cars catch on fire.
 

Attachments

Last edited:

HarryHoudini

Active Member
Joined
Jan 7, 2013
Messages
491
Reaction score
90
Points
28
Location
Australia
Members Ride
1991 VN Wagon..2012 VE Sportwagon.
Gawd,major drama there,i hadn't heard about the plug burning out.
When you took the back seat out there obviously wasn't a cut out in the floor plan above the fuel pump..?
 
Top