Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VE SS No Electrical power after one days rain

redhotss07

New Member
Joined
Nov 12, 2011
Messages
14
Reaction score
0
Points
1
Location
Inverell
Members Ride
'07 VE SS ute
Wondered if any1 could direct me on where to start looking. My 07 VE SS has been just sitting in the rain for 1 day and has no starting power, dash lights only. Need to move it by morning, Thank you.
 

WazzaV8

New Member
Joined
May 15, 2013
Messages
243
Reaction score
3
Points
0
Location
Esperance
Members Ride
VE SSV Redline
Have you tried jumper starting it, maybe flat battery, these days if they last longer than a year it's a bonus.
 

redhotss07

New Member
Joined
Nov 12, 2011
Messages
14
Reaction score
0
Points
1
Location
Inverell
Members Ride
'07 VE SS ute
will have 2 in the morning, pull battery outa G/F rav4, hope it has enough go, just don't understand y suddenly no power, wondered if any1 else had problems with rain/moisture, thx guys
 

somefool

Member
Joined
Jun 19, 2009
Messages
431
Reaction score
1
Points
16
Location
Adelaide, SA
Website
www.facebook.com
Members Ride
1991 VN 'S', 1997 Ford Laser 1.6
I have heard of water pooling in the drivers' side B pillar, causing a parasitic drain on the battery if left over time. One of the connectors down there getting wet. Could be worth a look
 

anarklov3r

Member
Joined
Aug 18, 2008
Messages
664
Reaction score
6
Points
18
Location
Melbourne
Members Ride
2007 WM Caprice
Have you tried shifting it out of Park and either back in or neutral?
 
Top